Slow ssh stash clones

I am running Stash 2.0.1 on Windows. When I clone my repo using the http url, it takes 5 minutes, when I use the ssh protocol - it takes 54 minutes. Anyone else experiencing this or fixed it?

6 answers

1 accepted

It not a Stash problem, this is problem of msysGit OpenSSH on Windows. See

To avoid this, you can use Cygwin's SSH (just copy over files). But this is not good solution, better way is to wait until developers upgrade OpenSSH in msysGit.

For temporary solution you can take theise files and override ssh.exe etc files in current mingGit installation:

This files is taken from latest Cygwin installation. You can make it on your side again, if you afraid to use this archive binaries. Just install fresh Cygwin from and copy over msysGit follow files:


Confirmed Alexey's answer works and closed my ticket with Atlassian about this issue.

We experienced slow Stash ssh hosted on Linux. This was caused by Java Issue with random generator and SSL stack.

Solution for Linux was to add following option to start options of Stash:

After adding this option and restarting stash transfer rate increased from less than 1 MB/s to more than 15 MB/s

0 vote
Jason Hinch Atlassian Team Jan 06, 2013

Many customers have reported slow push times on windows in Stash 2.x.x. The cause is not running Stash as a local non-administrator user. If you run Stash as a domain user and/or as a administrator windows often will make more file permission checks the repository is being modified on the server. These permission checks can be extremely slow.

This is assuming you are running your Stash server under Windows... Does not help us linux server people.

I am seeing the exact same problem...have a ticket in about it.

Hi Zachary,

If Jason's suggestions doesn't work, could I ask you to please raise a support issue at Our support engineers will need to have a look at your log files in order to help you with this problem.




I have installed Atlassian Stash on a Linux VPS client. There is an Apache HTTPD in front of it. I am running Ubuntu 12.04 on the server, I find Stash is really slow. Adding the flag


Make no difference to the speed.

I have confirmed that msysGit 1.9.0-preview20140217 causes cloning issues with Stash 2.11.2 and we upgraded to 2.12.1 and still have cloning issues on Windows Server 2008 R2. It pegs the CPU to 100% and fails; a restart of Stash Service is required. When I downgraded back to msysGit cloning worked again.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

293 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot