Pages whose tittle has a '&' character problem

I'm using confluence 4.0

And when I try to create a page whose tittle has a '&' character, that page is rendered normally but the URL of those pages is something like "http://<server>/pages/viewpage.action?pageId=5636721" insted of the normal http://<server>/display/<space>/<page_name> .

Is this a known issue? Is it correctable? Does anybody knows how?

2 answers

This is by design and afaik not configurable.

The whole issue is that the '&' character has special meaning in a URL. Therefore, Atlassian took it on the safe side to render the url for these pages by pageId. It happens to all pages with titles that give problems when the title is added to a URL.

This is still a feature request at the moment: Feel free to cast a vote to increase the popularity of the feature request or add yourself as a watcher to be notified for the future updates.

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

107 views 5 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot