Page content appears fine in browser but pages are blank when printing

When I print, the pages are blank except for the title of the site in the header of the printed page. I think I have narrowed the problem down to the "header" DIV (<div id="header" class="$!headerClass">) that is defined in the Main Layout decorator: when I remove that DIV, the page contents show up in the printout.

The problem is that the header DIV defines some styles that are important for the overall look and feel, but I can't figure out which one(s) are causing the printout to fail.

I've searched for display:none in the CSS and noprint DIVs in the decorators and have come up empty. I've also tried removing the styles that are defined in the header, one by one, until I removed all of them, and still no luck.

Any ideas?

1 answer

1 accepted

This widget could not be displayed.

Follow up to this: Could not find the cause nor the cure, but instead just added "decorator=printable" to the query string as a workaround.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 5 hours ago in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

23 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you