Ms Active Directory and JIRA, Users and group fetched but users in no groups

Hi!

I'm trying to get my JIRA and MS Active directory to work together. I've managed to connect to the AD and now it syncs. all users and all groups. But the users does not belong to the any group as in AD. I've added the users I want in a jira-users group in AD but they cannot login. I even tried setting up crowd and get the same result. The connection to Jira works but the connection to AD does not get any group memberships... Anyyone got any idea what might be wrong?

2 answers

1 accepted

This widget could not be displayed.
David Chan Atlassian Team Nov 17, 2011

It's hard to tell where it's failing. You can check your logs and see if any errors were thrown.

One guess would be a limitation in Confluence where duplicate groups listed in AD would cause memberships to fail:

https://jira.atlassian.com/browse/CONF-23213

Jira uses a similar LDAP integration, so I imagine it would have the same bug. I believe you can work around it by editing the Group Object Filter.

Example:

(&(objectCategory=Group)(!(CN=PAM Admin)))

Otherwise, I'd suggest opening a ticket at https://support.atlassian.com/ and having an Atlassian engineer take a look at your logs.

This widget could not be displayed.

Yes, that was exactly the solution to my problem! I more narrow filter qury solved it. Many thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 3 hours ago in Featured Groups

Hi! I'm Cameron Deatsch, Head of Server at Atlassian and I'm hosting an AMA next week.

Hey team! I'm Cameron Deatsch, Head of Server at Atlassian. I'll be hosting an AMA over in our Questions section of the Community next Monday, so shoot me your questions, upvote others' question...

19 views 0 2
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you