Latest SourceTree on Mac can't get past Account window

I updated SourceTree on my Mac.  Now I cannot get past the initial setup screen tying it to my Atlassian account.  I hit the "Use an existing account" button and get a tall, narrow and very blank window.  If I hit the "Go to My Atlassian" button, it prompts me to create a new account.  Hitting the "Use existing account" link gives me a 404 error. 

How do I get past this or go back to the previous version of SourceTree?

10 answers

I have the exact same problem, does anybody know how to fix this?


Uninstalled Source Tree and installed a previous build. Made it past the blank window.

Previous builds here:

same here with 2.2.2

I've the same issue with the Windows version

touch file name as accounts.json

full path: C:\Users\cnzzr\AppData\Local\Atlassian\SourceTree\account.json

contain content

    "$id": "1",
    "$type": "SourceTree.Api.Host.Identity.Model.IdentityAccount, SourceTree.Api.Host.Identity",
    "Authenticate": true,
    "HostInstance": {
      "$id": "2",
      "$type": "SourceTree.Host.Atlassianaccount.AtlassianAccountInstance, SourceTree.Host.AtlassianAccount",
      "Host": {
        "$id": "3",
        "$type": "SourceTree.Host.Atlassianaccount.AtlassianAccountHost, SourceTree.Host.AtlassianAccount",
        "Id": "atlassian account"
      "BaseUrl": ""
    "Credentials": {
      "$id": "4",
      "$type": "SourceTree.Model.BasicAuthCredentials, SourceTree.Api.Account",
      "Username": ""
    "IsDefault": false

Same issue, SourceTree 2.24 on Mac OS X 10.11.5
Select [Use an existing account] and get the empty long narrow window that shows a spinner and never shows anything else. 

Network connection likely blocked by my IT dept.

I can go to and download my license file.

HOW DO I GET PAST THE STUPID SETUP ASSISTANT and manually point sourcetree to my sourcetree license file that I downloaded from

I tried this and solved mine:

Open Safari and check if you can open If Safari complains it cannot create a secure connection, which is my case, goto key chain, find atlassian's cert, and check 'always trust', then try on safari again, if you can open it, then you are good to login source tree 2.2.2

Against my better judgement I tried to update to 2.3.x and ran into this.  What a horrible user experience.


I'm going back to 1.9.8.

Same problem on latest Windows version. I stopped using SourceTree a while ago because of some random crash that started happening. So I thought I'd give it another try now but can't even get it installed. Guess I'll wait another year or so and try again...

EDIT: So, after typing this and then going back to the installer (which I left running to come here), the blank panel was filled and I could log in after all. Maybe it's just a really laggy connection? YMMV

Sorry Atlassian to say that, but this registration dialog is real crap! I just had the same issue while trying to install Sourcetree on Mac. If I'm typing in my email address and press "Next" nothing happens (password field is not displayed). If I try to register via Google, I can't type anything in the field where the Gmail address is requested.

SOLUTION: Or maybe better "workaround": I was able to get the email (non-Google) variant running as follows:

1) Type in your mailaccount and press "Next" or <ENTER>

2) In the menu bar of Sorucetree (which is already available at that time), klick "SourceTree"=>"Settings". In the background the Settings window will appear.

3) Now when going back to the registration dialog you should see the password field!

gm I'm New Here Jan 26, 2018

I had the same issue, and your workaround saved me. Thanks!

I do not understand why they do not fix this (we are now in Jan 2018!): being the very first step in using a package, it's easy that people give up and go looking for a different one.

This really shouldn't be ignored by the software developers. I just had the same issue where the login screen was blank during installation. After about 5 mins it gave me the login screen with just the email address, filling that out and clicking next just caused it to hang again. It's obviously running some embedded browser and very poorly - on Windows it's obviously IE, as it gives you Explorer auto complete prompts etc which are completely unsuitable for a software login anyway...

Suggest an answer

Log in or Join to answer
Community showcase
Louis De Jaeger
Posted yesterday in Off-topic

Friday fun: your best joke

Hi all Lets make this Friday fun really fun and post one (or more) of your best jokes! The joke can be about an Atlassian product, or just a really fun joke you want to share! I’m not the best j...

157 views 12 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot