Issues are not getting created through email though the test-connection was successful

Hi JIRA lovers,

I have created a mail handler to create issues and comments from email. Though on testing the connection it shows that 3 messages read and 2 JIRAs are created, still later NO issues are getting created. I also received new messages on that email which are supposed to be picked up by JIRA for issues creation.

Kindly help.

Thanks,

Mohini

1 answer

0 votes

You'll need to read the log to find out what's going on.

Jira won't make much noise when issues are created successfully, but it will tell you if it processes and drops incoming emails. Could be any reason though - sender not having create issue rights in the project is the usual one, although you might find that others are being added as comments because they match existing issues.

If mails are disappearing completely, then you need to look at the mailbox. The fact you're saying "I received new messages on that email which are supposed to be picked up by Jira" strongly suggests you've got an email client pointed at the same mailbox, which could easily be removing the emails before Jira gets to see them...

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

47 views 2 4
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you