How to connect Squish to Jira (xml2jira)?

I am trying to connect squish (gui testing) to jira. I keep getting xml errors, I am using JIRA 3.1 version and squish 6.1. Please help.

3 answers

2 votes
Sam Hall Community Champion Jan 24, 2017

HI Saruthaemany,

Hopefully someone on here will be able to help, but did you try contacting froglogic directly? They have a support page here: https://www.froglogic.com/support/

Sam

0 votes
Sam Hall Community Champion Jan 24, 2017

You'll probably need to give a few more details about exactly what is happening to get a good answer on here. What exactly is the error? When does it happen?

Tried xml2jira script which is:

xml2jira --server http://jira:8080 --user alice --password al1ce --project SampleProject --component tests --reportfile C:\report.xml

updated the above code with username password and our xml file. The following error messages are seen.

The error message are:

1. expected ‘.’ In report version string ‘3’

2. expected ‘name’ attribute missing for element ‘test’

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

51 views 2 4
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you