Error While Posting Comment In Confluence

When trying to add a page comment, we are encountering the error described on this page:

https://confluence.atlassian.com/display/ONDEMANDKB/Error+While+Posting+Comment+In+Confluence

The solution described seems suitable for the on-demand edition, however we have a local installation of Confluence.

Has anyone encountered and resolved a similar issue?

2 answers

1 accepted

Accepted Answer
0 votes

Hey there, I think you might be encountering the issue mentioned in this KB - https://confluence.atlassian.com/display/CONFKB/Unable+to+Add+Comment+Due+to+Enabled+MySQL+Mode+NO_AUTO_VALUE_ON_ZERO

Give it a check and hope it helps to fix the problem.

This is the solution that worked - quite a simple one in the end. It could be worth mentioning which values are appropriate for sql_mode (if any) in the Confluence setup documentation.

It might be caused by corrupted plugin cache or index. In order to fix that, please rebuild index from scratch and also clear plugin cache.

Thanks for these suggestions - I'm just waiting until I can schedule some downtime to try them - will let you know how I get on.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 9 hours ago in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

56 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you