Custom AtlassianWikiRenderer in JIRA 7.3.x not working

We have a custom renderer which extends AtlassianWikiRenderer. This works fine up to JIRA 7.2.x but starting with JIRA 7.3 (the version with the embedded Rich Text Editor) these kind of renderers suddenly stop working.

The symptom is that the tabs "Text" and "Visual" do not show up anymore while editing fields using the custom renderer.

Has anyone experienced similar trouble?

If this is an intended behaviour, how can I use custom renderers on Rich Text Editor?

Use Case: We want to display text matching a specific pattern to a link to an internal server containing the text, e.g. "tx-foobar" matching "tx-\w+ " --> "https://my.server/app?id=tx-foobar&action=open"

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 6 hours ago in United States

Topic Tuesday: What's your favorite topic?

Good morning All, Our goal is to get you into the habit of while enjoying your favorite morning drink you are checking the NOVA "space" for topics and comments. Your input is really needed and...

25 views 4 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you