Confluence v5.10 Insert Link, 'Link text' field sometimes missing.

This question is in reference to Atlassian Documentation: Configuring issue linking

I wonder whether others have noticed this. Occasionally when editing a page the Insert Link (Ctrl-K) feature's dialog box omits the Link text option.

I've found that this occurs when you select (for linking) text that includes non-alpha characters. The workaround is to ensure you don't select non-alpha characters before pressing Insert Link. You can then enter the non-alpha characters in the dialog's Link text field.

Confluence-LinkTextMissing-Sanitized.png

2 answers

This widget could not be displayed.

I see that I wrongly associated this question with (Jira?) Issue Linking. It's more general.
Apologies. 

This widget could not be displayed.

Scott, thank you for that workaround. I'd previously been mystified by why the TEXT field (in Confluence) is sometimes missing.

I tried to make a link out of "step 1" but was missing the text field . But, removing it worked for me.

I wonder if this issue has been officially reported to Atlassian?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

140 views 16 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you