Confluence v5.10 Insert Link, 'Link text' field sometimes missing.

This question is in reference to Atlassian Documentation: Configuring issue linking

I wonder whether others have noticed this. Occasionally when editing a page the Insert Link (Ctrl-K) feature's dialog box omits the Link text option.

I've found that this occurs when you select (for linking) text that includes non-alpha characters. The workaround is to ensure you don't select non-alpha characters before pressing Insert Link. You can then enter the non-alpha characters in the dialog's Link text field.


2 answers

I see that I wrongly associated this question with (Jira?) Issue Linking. It's more general.

Scott, thank you for that workaround. I'd previously been mystified by why the TEXT field (in Confluence) is sometimes missing.

I tried to make a link out of "step 1" but was missing the text field . But, removing it worked for me.

I wonder if this issue has been officially reported to Atlassian?

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

105 views 2 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot