It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"The issue index inconsistent with the database state"

Capture234.PNG

Hello, we performed a reindex a few hours ago in an attempt to get rid of this error.

Our "Create new issue", "add comment" alongside other actions take a long time to go through and we suspected that this was the reason.

Server Version 7.2.3

 

Thank you for all and any input about our problem...

1 answer

0 votes
Peter DeWitt Community Leader Nov 12, 2019

@Viva Bot , Indexing and troubleshooting index problems can be tricky. Here are two articles from Atlassian with suggestions and troubleshooting support:

https://confluence.atlassian.com/jirakb/troubleshoot-index-problems-in-jira-server-203394752.html
https://confluence.atlassian.com/jirakb/lucene-search-indexes-health-check-fails-in-jira-server-740263412.html

The first is a general guide while the second is a bit more specific to what you are seeing.

You indicated that you have performed a reindex. Was it a back ground reindex? if so try a lock and rebuild. I have also had success in the past deleting the index completed and allow Jira to re-create all the associated directories & files. (backup the existing index first just in case).

-pjd 

Thank you, we did a lock and rebuild but it didn't help.

Those are exactly the articles we were viewing yesterday actually before deciding the lock and rebuild reindex.

Peter DeWitt Community Leader Nov 12, 2019

Hmmm. Have you opened a support ticket with Atlassian Directly. Also, look at your plugins - are they up to date? One of those guys could be the culprit.

Unfortunately, since we are decommissioning our Jira Server installation and moving to JIRA Cloud, we are not going to renew our server license in order to request support from Atlassian directly. 

Nevertheless, we are trying to fix this issue since the Jira Cloud instance migration is only partially done.

Peter DeWitt Community Leader Nov 13, 2019

The last time we got stuck with an Index issue it was due to an add-on, here is what we did. Maybe this will help:

  1. Back-up you existing Jira Index.
  2. Put Jira into safe mode. This disables all apps.
  3. Shut-down Jira and manually delete the index files/folders. Jira will re-create these the next time it builds the index.
  4. Start Jira and rebuild the index. The only option you should have is lock & reindex.
  5. Take Jira out of safe mode.
  6. Restart Jira
  7. Lock & Rebuild the index to add all of the app data in.

Enabling safe mode:

https://confluence.atlassian.com/upm/disabling-and-enabling-apps-273875716.html

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you