jelly sends mail even with no mail server defined in jira

I have deleted all smtp and pop servers from my jira. if i go to admninistration->send mail i get a message saying that i need to configure my email server first.

However, if i run a jelly script on the same server telling it to send mail -- the mail is sent.

I have disabled the scripts for now, but many mails have been needlesly sent. could you point me to documentation about how jelly sends mails? without using jira's email server definitions?

3 answers

It really should be possible, are you sure outbound smtp server configuration was removed before the jelly scripts were run?

I suppose its possible that the jelly service is somehow caching the information. If you restart after removing the smpt server details, does the problem persist?

I've restarted jira and tried sending mail through jelly again, and it worked. So i suppose jelly somehow caches the smtp server's details. In a way that is persistent across restarts. This is good to know.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

25,317 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you