Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Updating issue types not working

After any update (title, icon) of the issue type name, changes are not visible in CREATE issue screen (Issue type field). Any ideas what's the problem?

Thanks,
Ewa

1 answer

0 votes
Rachel Wright Community Leader May 25, 2017

Hi Ewa,

First, I'm assuming that the project you're trying to create in includes the issue type you've changed.  (In other words, the problem isn't that you're not seeing the issue type at all, it's that you're seeing the old name and old icon, right?)

Assuming this is correct, have you tried a reindex?  I haven't personally experienced this problem, but that's what I'd try.

Please keep in mind a reindex will either make your app temporarily unavailable (if you choose the "lock and rebuild" type) or may impact performance (if you choose the "background" type.)  You'll want to do this after peak use hours.

Please let us know if this solves the problem.  I'm interested in the final solution.

Good luck,

Rachel Wright

Hi Rachel,

Thank you for your response! Reindex doesn't work. The only workaround is JIRA restart or opening issue types scheme, edit, and save without any changes. I always feel silly to do it :)

This is known issue: https://community.atlassian.com/t5/JIRA-questions/Changes-on-issue-type-icon-are-not-visible-in-combobox/qaq-p/208324 

Editing issue type use to work without any problems before, I just think it should be fixed...We use JIRA 7.2.7.

Thanks!

Ewa

This doesn't sound like a "known issue" I can find, and changing the names of issue types worked fine for me on JIRA 7.2.

I suspect there's something interfering with the edits - could you have a look at the log files to see if there are errors happening around the time you are making the edits?

Maybe this one will be similar? It happens with the issue type name or icon: https://jira.atlassian.com/browse/JRASERVER-60897 

All changes are visible in admin mode, but not when you open CREATE issue screen. 

Don't see any errors in my logs :/

Ah, yes, that's the bug.  Couldn't find it earlier.

It's not happening on my local one, so I can't replicate it, but the bug does say it's intermittent.

And additionally I can't setup Default issue type value...Any updates on that? Any possible fix?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you