Unable to attach file to ticket

When hitting the site using our external domain name, www.domain.com/jira, I am unable to upload attachments to a ticket. When hitting the site via servername.subdomain.domain.com/jira; I am able to upload any attachment just fine. Our standardized way of hitting the site is via www.domain.com/jira.

I'm not sure when this issue started. I cannot find anything in any log pointing to a potential problem with any configuration.

In our environment all requests get routed through apache, using mod_proxy AJP.

This issue occurs with various file types and sizes.

7 answers

1 accepted

So in my particular case, I use Chrome as my browser of choice. After further testing and other users assisting, it would appear that even after closing and restarting the browser, some data was still cached which caused the problems.

After clearing all browsing data that Chrome stores, I was then able to upload an attachment just fine.

Hi John,

Which error message displaying in atlassian-jira.log file. Please let me know.

Thanks,

Patina

Patina,

Nothing is added to the atlassian log when this issue occurs.

I'm running JIRA 6.0.2#6097-sha1:e270beb

Hi John. Have you checked your Apache access/error logs?

Yes, unfortunately nothing helps lead me anywhere. There doesn't exist anything in the error logs related to this issue, the access logs have only the following:

10.0.0.30 - - [07/Jan/2014:11:58:12 -0500] "GET /jira/secure/AttachFile!default.jspa?id=43820&decorator=dialog&inline=true&_=1389113890089 HTTP/1.1" 200 1684
10.0.0.30 - - [07/Jan/2014:11:58:13 -0500] "GET /confluence/rest/quickreload/latest/3440826?since=1389113873624&_=1389113890974 HTTP/1.1" 200 46
10.0.0.30 - - [07/Jan/2014:11:58:16 -0500] "POST /jira/rest/internal/1.0/AttachTemporaryFile?filename=attach_file_fail.png&size=46943&atl_token=AO0T-CK0B-6YFX-F0HP%7C9f4ccb913d7762996fe972990da668e11d186203b4%7Clin&issueId=43820 HTTP/1.1" 201 77
10.0.0.30 - - [07/Jan/2014:11:58:19 -0500] "POST /jira/secure/AttachFile.jspa HTTP/1.1" 200 1750

Which isn't very helpful. Even though the above looks normal; The attachment fails to upload.


Is it affecting other users? Also can you track when the last successful upload occured?

Hi John,

Try restart the jira. Problem seems to be gone after restart.

And try with other browsers. and Try to re-attach again. If problem still exists let me know.

Thanks,

Patina

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,011 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot