''Transition parent when all subtasks are resolved'' no longer working

So Here's what I've got.

  • Sub Task blocking is enabled on almost every step on the Parent Workflow.
  • Transition Parent when all subtasks are resolved enabled on every step of all sub task workflows
  • All transition ID's have been double checked and are correct. All Subblocking status' are correct.
  • The Parent Transition function was working fine. It is now not working fine, but I'm not sure why.

I don't think I've changed anything within the workflows, so I'm really confused as to why this function has stopped working.

All plug-ins are up to date.

Some changes I have made;

I installed the status color .jar file
I have edited the preferences file so that the number of options outside the workflow button are increased to 4.

Is there anything else that could stop this from working?

6 answers

This widget could not be displayed.

What function isn't working ? Is it the subtask-block checking or the auto-transition parent when all subtasks are resolved?

This widget could not be displayed.

Is this a function from the script runner or some other plugin?

This widget could not be displayed.

Hi.

It is a script runner function. I have updated the main post, but the problem is that the Parent Task is no longer automatically transitioning.

This widget could not be displayed.

I have done. I've done single changes everywhere. The only real solution I can see is to make a new workflow and copy it word for word and see if there's anything I spot, or if that fixes it in anyway.

Quick question, is it possible that adding things such as 'Only Users in this role can transition...' or Multiple subtask blocking set ups could simply cause them to cancel each other out?

This widget could not be displayed.

Well... something must have changed if it was working. You may have to rack your brains a bit more. Can you try the same workflow in a test project?

This widget could not be displayed.

I wouldn't have thought so.

> I have done. I've done single changes everywhere

I don't really understand what you mean - did you try the same workflow on another project and it worked, or it didn't?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

578 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you