Post Functions - Create Subtask does not work on a specific project

Hello, 

I created a custom issuetype called X and workflow X which has 20 post functions. When I try it on a specific project none of the subtasks are being auto created. When I use the  issuetype X /workflow X on any other project , all subtasks are being auto created with no issues. What can be the problem for this project?

Thank you for your help.

Elif

 

1 answer

1 accepted

0 votes
Accepted answer

Does the user running it have the right to create issues in the project?

I suspect it's more likely to be content though.  Does the project include the right sub-task type?  Can you create a sub-task manually?  Are there validators or mandatory fields your post-functions don't take into account?

@Nic Brough [Adaptavist] , you were right. Issue type sub-task was not exist for that project. Duh!!!

 

Thanks so much!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,741 views 17 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you