Post Functions - Create Subtask does not work on a specific project

Hello, 

I created a custom issuetype called X and workflow X which has 20 post functions. When I try it on a specific project none of the subtasks are being auto created. When I use the  issuetype X /workflow X on any other project , all subtasks are being auto created with no issues. What can be the problem for this project?

Thank you for your help.

Elif

 

1 answer

1 accepted

0 vote

Does the user running it have the right to create issues in the project?

I suspect it's more likely to be content though.  Does the project include the right sub-task type?  Can you create a sub-task manually?  Are there validators or mandatory fields your post-functions don't take into account?

@Nic Brough [Adaptavist] , you were right. Issue type sub-task was not exist for that project. Duh!!!

 

Thanks so much!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

759 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you