Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA doesn't create comment when using IMAP

So basically we have set up an IMAP email inbox to receive jira emails and distribute them to different mail folders with mail rules. A jira mail handler has been set up to monitor each folder and the option is to "create a new issue or add a comment". Each folder corresponds to a different pair of project and issue type. "Strip Quotes" is checked and default reporter has been added just in case. The rest is following the jira default. Also the outgoing "From" is set to use the IMAP email address.

During my testing, new jira can be created successfully. However, comments cannot when I replied to a new jira email. I found out the replied email was routed to the correct folder but somehow not processed by the mail handler. When I used the test option in mail handler, it only says the test was successful as below without mentioning what has been done or what was wrong -- it's supposed to create a comment.

1 message read from the server.
Found 1 message(s) in the imap folder.

(and that's it)

As a comparison, we used POP option before and it can create new jira and comment from reply but we have to switch to IMAP due to some IT requirements.

Did anyone experience the same issue? Please advise me.

6 answers

1 accepted

0 votes
Answer accepted

Are you referring your folder in the incoming IMAP mailbox config?

Log Email Protocol details to see what is happening, the answer will be there:


Can anyone help?

What is the default account you are using in your mail handler? If the person responding to the JIRA email does not have a JIRA account then it will default to the user you specified. If you set a default user, does that user have permission to add comments in that project?

Yes, the default account is a registered jira user with permission to add comment. In my test, I also tried a different jira user (non-default but also with permission) to reply to the jira email. Pop worked but not IMAP -- no error or anything as I mentioned earlier.

How can I investigate it? Is there any log I can turn on to troubleshoot?


I processed two emails respectively: one should create a new jira and the other one should add a comment to the existing jira.

1. It didn't create a new jira with this error: javax.mail.MessagingException: Unable to load BODYSTRUCTURE

2. It didn't add comment with this error: [com.atlassian.mail.MailUtils] IOException whilst getting message content BASE64Decoder: Error in encoded stream: needed 4 valid base64 characters but only got 2 before EOF, the 10 most recent characters were: "al\r\nX-MS-H"

Can you advise how I can troubleshoot or fix these issues?



#2 issue has been resolved and it was an IMAP config issue.

#1 is still open.

@jack wang what is the IMAP config issue here? I also see this error. Thanks in advance.

I am seeing this error too and am interested in the fix.

Too bad he didn't post the solution. Now I'll have to open a ticket with Atlassian.

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you