Invalid statuses/buttons still available after changing issue type

We have two issue types that are concerned. Bug, which goes from Code Review to QA to Staging, and Hotfix, which goes directly from Code Review to Staging. We've noticed that something strange happens: if you start a ticket as a bug and get as far as code review, and then change the issue type to hotfix, the Advance to QA button is still available, rather than hiding that button and displaying the Advance to Staging button.

Why does this happen, and how can I fix it? (I have administrator access and can edit workflows and screens if necessary.)

1 answer

This widget could not be displayed.

Have you assigned the different workflows to the issue types? If yes I would suggest doing a reindex and/or integrity check.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

564 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you