How do you remove 'NONE' from a select list or radio button custom field?

I am using Jira version 7.2.6 - i have tried making the fields 'required' on the customer field configuration but that doesnt work. 

2 answers

You have to specify a default value for that field. You can do this under Customfields -> Configure -> Edit Default Value

hi i have tried that but the 'none' option is still present. 

It's default and mandatory - have you done both?  (Both are at an issue level too, not project)

I have just tried that too and its still there. When you say issue level do you mean the custom field is assigned to an issue type?

Yes, but also the configuration - you can give an issue type a "field configuration" that differes from other issue types in the same project (and, of course, across different projects). 

When I mess up fields, 75% of the time it's because I have associated the wrong field configuration, and 24% of the time, I've got the context wrong.

I have just checked and i have already assigned a field configuration for that issue type. I have also assigned the custom field to the same issue type and i have set a default value & made the field mandatory.......AND its still there :( 

Joe Pitt Community Champion Jul 27, 2017

The default is assigned at the custom field definition level in the context, if you have different ones by project or issue type.

You must be missing something in the configuration.

I've just created a new radio button field with three options, and made it mandatory in the field configuration (for all issue types in the project).

None is no longer an option when creating a new issue.

One other thought though - could someone have added "none" as an option in the list of options for the field?

what version are you using?

JIRA 7.4 for that test, but I've also just tried it on 7.2, 6.4 and 5.2 to make sure my memory of the behaviour is correct.

Was this ever resolved? I'm on version 7.3.1 and also can't hide the None option in the radio buttons via the configuration. I've rest the configuration to Required, made the default option Yes, and I still see None on the screen. I re-indexed and still no luck. I can't remove the option from the entire system because none is an option in other custom fields. Am I missing something?

In the end I succeeded using SIL as follows:

1. Instant hook on the issue type

2. Instant action as follows:

if(argv["screen"] == "create") {
    if (argv["issueType"] == "xxxx") {
        lfRestrictSelectOptions("customfield_xxxx", {"None"});

But I understand that the more code I put behind the scenes, the slower things will run so I'd like to do this in the configuration if possible.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

93 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you