It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error then importing external project i have an error Edited

hi

this kind of error

""An error occurred whilst rendering this message. Please contact the administrators, and inform them of this bug. Details: ------- org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getFormTitle' in class com.atlassian.jira.plugins.importer.web.ImporterLogsPage threw exception java.lang.NullPointerException at /templates/standard/jiraformheader.vm[line 11, column 14] at org.apache.velocity.runtime.parser.node.ASTIdentifier.execute(ASTIdentifier.java:223) at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:262) at org.apache.velocity.runtime.parser.node.ASTReference.evaluate(ASTReference.java:470) at org.apache.velocity.runtime.parser.node.ASTExpression.evaluate(ASTExpression.java:62) at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:85) at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:336) at org.apache.velocity.runtime.directive.Parse.render(Parse.java:263) at org.apache.velocity.runtime.parser.node.ASTDirective.render(ASTDirective.java:175) at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:336) at org.apache.velocity.Template.merge(Template.java:328) at org.apache.velocity.Template.merge(Template.java:235) at org.apache.velocity.app.VelocityEngine.mergeTemplate(VelocityEngine.java:381) at com.atlassian.velocity.DefaultVelocityManager.writeEncodedBodyImpl(DefaultVelocityManager.java:117) at com.atlassian.velocity.DefaultVelocityManager.writeEncodedBody(DefaultVelocityManager.java:97) at com.atlassian.jira.template.velocity.DefaultVelocityTemplatingEngine$DefaultRenderRequest.toWriterImpl(DefaultVelocityTemplatingEngine.java:122) at com.atlassian.jira.template.velocity.DefaultVelocityTemplatingEngine$DefaultRenderRequest.asHtml(DefaultVelocityTemplatingEngine.java:113) at com.atlassian.jira.web.dispatcher.JiraVelocityViewDispatcher.dispatch(JiraVelocityViewDispatcher.java:51) at com.atlassian.jira.web.dispatcher.JiraWebworkViewDispatcher.dispatchViaVelocityView(JiraWebworkViewDispatcher.java:89) at com.atlassian.jira.web.dispatcher.JiraWebworkViewDispatcher.dispatchView(JiraWebworkViewDispatcher.java:56) 

3 answers

1 vote
Andy Heinzer Atlassian Team Sep 10, 2019

Sorry to hear about this problem.  Could you please let us know more details here?  Such as

  • What version of Jira is this?
  • What kind of import is this (csv, trello, project import, other)?

With the stacktrace we see right now, we don't know what caused this error.  It is possible that before this error or after it there could be another stracktrace that would provide us with more details about why this particular import is failing here. 

Curious to learn more about this problem.

Andy

trello

Jira Software 8.2.4

 i will try

0 votes

Hello @Amigo

Welcome to Atlassian Community!

In order to better troubleshoot the problem, please provide us with the following information so we can confirm we are on the same page:

1 - You mentioned that this error occurred when you tried to Import an external project to your JIRA instance. Can you confirm from which application this project was generated (Other JIRA instance, Trello, etc) and what is the method you are trying to import the project (JSON, CSV, etc)?

2 - Can you provide us what is the platform of your JIRA Application (Cloud or Server)? If it is Server, can you let us know what is your version?

3 - Check if the steps of the documentation below work for you:

Project Import of Software project fails with Unexpected import failure

4 - If you are trying to import a project from Trello, Check the following details:

   - Check if you imported that project before and removed it in your JIRA application. If you did, navigate to JIRA Settings > Issues > Workflows and delete all the workflows related to that project, then try to add it again.

   - If your instance is entirely new and doesn't have any projects in it, try to create a single project and import the file again.

We will be waiting to know your results to further help you. :)

hi

it from trello

LEXORANK clean
isssues deleted..

Hello @Amigo

Have you also checked if the Workflows related to your Trello board are existent in your Jira as suggested above? Since you imported it from Trello, I believe it might be causing your issue.

0 votes
Dario Atlassian Team Oct 24, 2019

Hello @Amigo ,

Sorry for jumping into an old thread but the exact same error message (below) was once also thrown when importing from Trello into Jira Cloud:

 .... Invocation of method 'getFormTitle' in class com.atlassian.jira.plugins.importer.web.ImporterLogsPage threw exception java.lang.NullPointerException at /templates/standard/jiraformheader.vm[line 11, column 14] .....

 

The issue was tracked as [JRACLOUD-65400] Error in Trello Importer: java.lang.NullPointerException for Jira Cloud, and the root-cause was the following:

The issue seems to happen when a project is imported from Trello, then removed and imported again. The root-cause is that the workflows created by the first import are not removed when the project is deleted.

In order to be able to import the same project again you have to remove workflow(s) and workflow scheme(s) created by the first import.

 

In the last comment, from February this year I can read:

Still an issue on Jira Server (v7.5.0#75005-sha1:fd8c849), it is very easy to replicate, just import a board with checklists in cards, delete the project and try to import it again.

FIX: 

  1. Delete Workflow Schemes (found under inactive)
  2. Delete Workflows (found under inactive)
  3. Import again

 

Can you kindly test this and let us know if it fixes the issue?

 

Cheers,
Dario

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

273 views 1 2
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you