Error log related to Scripted jql function

Hi everybody,

i'm getting the following error in log file

ERROR tsol 860x182118x2 l54c9w 10.0.9.115,10.0.8.55 /issues/ [jira.groovy.jql.ScriptedJqlFunction] Function scriptedFunction didn't have a data type, returning Issue. Possibly plugin not started yet

I'm getting the error quite often.

I don't know for what reason i'm getting this error.

I tried to reproduce on my own by doing some actions but without luck.

Should i change something on the plugin?

Cheers,

Kostas

2 answers

1 accepted

Accepted Answer
2 votes

Kostas, this is an issue that I am working on. I don't think it means there is any problem but yes it it's annoying.

You could set the log level to fatal for that class if you wanted, but I will try to get a fix for this soon.

Thanks a lot Jamie,

Cheers,

Kostas

Same problem here (JIRA 5.1.5), initially the scripted jql functions didn't work at all for me returning this particular error on the log. When I try the scripted jql function from the preview page they work alright, but when I try to use them on the Issue Navigator's JQL search they refuse to work.

And the funny part now, after leaving the server to rest for one night, I return, login again and voila the functions work. The early indicator was that when I was composing the JQL after typing the "in" operator I got the drop-down with available functions, which was not the case before. I don't remember doning anything in particular to make it work, only that I played around with the previews and tried to create one function from scratch.

Cheers,

Aggelos

Hi Aggelos... I'm going to try to reproduce this... unfortunately this is only a problem I've seen in production systems. What version do you have?

BTW disabled and enabling the script runner plugin should remove the error and get things working, but only until the next time this unexpected thing happens that I can't work out atm...

Running 2.1-BETA-4. BTW, disabling individual JQL functions doesn't work, can you reproduce this?

Doesn't work in what sense? I mean if you disable and enable the entire plugin from manage plugins, that should get everything working? I'm still working on reproducing the causes of the log message.

In secure/admin/groovy/ViewScriptedJqlFunctions!default.jspa there is a "Disable" action for each function, when I press it nothing happens, I mean I would expect that the "Enable" will be active as a result, but the UI stays the same and the functions is still available to use when searching.

OK. Can you check the logs for errors? Most likely something is failing. If so could you create a bug at https://studio.plugins.atlassian.com/browse/GRV.

Sorry Jamie, nothing special on the logs. Extra logging will help?

Still investigating this in another instance, will get back to you.

What's the return value of the function? (I am just reading the log you have given and speaking)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

456 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you