Error doesn't allow cloning an issue due to an attachment validator when creating a ticket

Josh Busch April 11, 2024

This error appears when trying to clone a ticket, "com.atlassian.jira.exception.createexception: Error occurred while creating issue through workflow"

I've looked into the validators and the logs to try to locate the issue. There is a validator on creating a ticket that requires the issue to have an attachment. And that's the same error, "Attachment is required", which appears in the log. But the ticket I am trying to clone has an attachment and I click the "Clone Attachment" check box when trying to clone my issue to make sure it retains the attachment. Yet it still throws the same error. I tested removing the validator that requires an attachment on creation and then cloning the issue and the clone operation worked just fine. But the user I am building the workflow for said they wanted the validator in there. So I'm wondering why the validator is throwing the error when it has an attachment and if there is another way to make this work.

1 answer

1 accepted

1 vote
Answer accepted
Marc Koppelaar - Devoteam
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 11, 2024

Hi @Josh Busch 

The reason on this is that when cloning an issue, the validation is causing the problem.

See alos; JRASERVER-76123 

So the error you are getting makes sense in this way.

A W-O is to use a workflow extension app from the marketplace, like JWME or Scriprunner

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events