Eclipse plugin stops working, JSONException

I've been connecting to a JIRA repository using Atlassian Plugin 3.2.2.v20130909 in Eclipse Kepler release 20130919-0819.

I believe I changed some piece of data in the repository in some way such that all attempts to run queries in Eclipse using the plugin fail with this error message:

org.codehaus.jettison.json.JSONException: JSONArray[0] is not a JSONObject.

The same queries succeed when accessing the JIRA with a web browser client.

What does this mean and what is the workaround for it?

1 answer

Hi Steve, We will need more data to investigate the issue. Please open a support request and we will try to find what is wrong: https://support.atlassian.com/browse/ECSP Cheers, Jacek

I opened a support request and it is being worked.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

708 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you