Eclipse plugin stops working, JSONException

I've been connecting to a JIRA repository using Atlassian Plugin 3.2.2.v20130909 in Eclipse Kepler release 20130919-0819.

I believe I changed some piece of data in the repository in some way such that all attempts to run queries in Eclipse using the plugin fail with this error message:

org.codehaus.jettison.json.JSONException: JSONArray[0] is not a JSONObject.

The same queries succeed when accessing the JIRA with a web browser client.

What does this mean and what is the workaround for it?

1 answer

Hi Steve, We will need more data to investigate the issue. Please open a support request and we will try to find what is wrong: https://support.atlassian.com/browse/ECSP Cheers, Jacek

I opened a support request and it is being worked.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,311 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot