Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Dashboard shared with project, but not visible for all groups in project

Hello, I have a dashboard shared with project A. On the dashboard are 5 different filters, also all shared with project A. I have 2 users:  user1 and user2. User1 is member of several project roles in the project and can see the dashboard correctly, user2 is only member of projectrole "users" and he get's several errormessages on the different filters/gadgets:

- on the "filter results": errormessage "The filter configured for this gadget could not be retrieved. Please verify it is still valid on the issue navigator."

- on the Pie Chart gadget: errormessage "Unfortunately, one or more of your preferences are now unavailable. Please update your preferences, or remove gadget by clicking delete from the title bar above.". 

I use both users on the same laptop, same Jira instance, same browser (version). What can be the issue? Thanks for the help. 

3 answers

1 accepted

0 votes
Answer accepted
Moses Thomas Community Leader Jun 04, 2018

@Sandra MeessenMake sure that user's  have access  to  filter,  ie  it's not  set to  private.

Hello Moses, I checked: both dashboard and all used filters are shared with "project" (so all groups in projectA). What can be the problem?

@Sandra MeessenCheck  this, since you  are the one that created this filter it should appear on  your favorite filters  click  it the filter and then go  to  Details  at  top of the search  boxSelection_005.pngThen choose  project, as shown, Click  the Add  then  Save

Now users /groups in  project A should have Browse project permission, i  think  this should work.

 

Best!

Like # people like this

This is all in place for all used filters in the dashboard. That's why we don't understand what is happening. Some groups see the filterresults and some don't. 

Moses Thomas Community Leader Jun 07, 2018

@Sandra MeessenI suggest  you  check  those groups  that  don't see,  make  sure they  have "browse project  permission"  in the permission scheme for this project A , it should  work,  please very  this.

Yes, that's also in place for specific groups. 

Moses Thomas Community Leader Jun 07, 2018

@Sandra Meessen

One more thing  to  check  verify that users  are in  the group    which  you  have given browse project permission in project  A.

That's also in place.

OK. 

 So create a new board,  create new filter,   and share it again according to all dependencies taken into  consideration in our previous talk , and  see just to  verify  that is a bug or not

 

best!

I am also facing the exact same issue. Sounds like a bug.

I'm also seeing this. I just received a user issue saying he can't see the dashboard gadgets (he added the dashboard as a favorite but all the gadgets say "Unfortunately, one of more of your preferences are now unavailable.  Please update your preferences, or remove gadget by clicking delete from the little bar above") but others on his team can.

The dashboard was created by his manager so I checked to make sure the filters were shared and they were. The filter is shared with a user group.  I then verified that the user was part of that group and he is.  Others on his team can see the dashboard but he cannot.  

Could please Atlassian Team suggest a resolution for this issue? 

I am having exactly the same issue.

Though the owner has shared the Dashboard but the user has to do following steps:

Go to Manage Dashboard,

click on search link,

Enter the Exact Dashboard name, 

select owner name

select shared with. ( project ,  select project from dropdown, All)

Make it favorite

Yes, This worked. Thanks Raj

This doesn't work for me. My dashboard is shared with a Group. The users can see the dashboard, but they can't view the gadgets on it.
All the previously suggested points above are in place.

Here's my error:

2019-08-12 10_44_04-Clipboard.png

I think this is what Moses and Raj suggested above, but I'm reframing it in a way that makes more sense to me:

Your gadgets and dashboard may be visible, but those based on filters you have saved in search will be blocked because the filters themselves are set to private by default. To fix this:

1. Click the Issues tab.

2. Scroll down to and select "Manage Filters".

3. Click the gear wheel next to each filter used in your gadgets and add users as needed (jira-users is the broadest and offered by default).

Your gadgets should now appear in the relevant dashboard for any users you shared the filters with.

Worked - clearly explained. Thank you Jeremiah.

 

Also, Attlasian, why is it not plausible to present users trying to share private filters with that information so they know what's causing the issue and how to fix it? 

Thanks for this description. Helped with fixing the issue for my team. 

Does this really need to be done for all Filters, or can you set defaults for Filters or open them all up in bulk somehow?

Yes we need to do this for all the filters i believe

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you