Confluence page link error in Jira

Hi All,

I have the following problem:

I try to link a Confluence page in a Jira issue. When I search for the page, I get the result. But when I save the link, the link panel says "No Confluence page found with the given URL."

What is wrong? The Jira found the page but then responses that it weren't found???

Can you please help?

Thanks in advance,
Rumi

6 answers

1 accepted

This widget could not be displayed.

What happens when you do the same search in Confluence itself? Does reindexing in Confluence fix this?

What happens when you search? And are there any permission differences?

Hi Jobin,

when I directly insert the URL to the browser, it navigates to the proper page in Confluence.

I am Jira administrator and have access to all spaces and it doesn't work for me too.

This widget could not be displayed.

I am having the same problem. On Confluence 4.3.2 and JIRA 5.1.7.

The odd thing about our config is that both are on the same server and Confluence and JIRA have different user directories.

This widget could not be displayed.

Hey Rumi,

In your logs you might be getting something like

Failed to load Confluence Page from remote server Caused by: java.io.IOException: Failed to load Confluence Page from remote server Caused by: com.atlassian.sal.api.net.ResponseException: Status Code: 200, Status Text: OK, Errors: {}, Error Messages: [java.lang.Exception: com.atlassian.confluence.rpc.RemoteException: You're not allowed to view that page, or it does not exist.]

Can you please check if that is the case?

This widget could not be displayed.

I had this problem and was able to resolve it by allowing Anonymous read-only access to Confluence. Part of the problem is that our user directories are different in JIRA and Confluence at this time, which we plan to fix soon. In the meantime this works fine since our wiki is not publically accessible anyway.

This widget could not be displayed.

I run Jira and Confluence on two different Domain Names. When I insert a Jira Ticket into a Confluence Page, Jira tries to show the Page in the 'mentioned in' area. Unfortunately an error occurs everytime the Confluence Page is loaded. This is the message in the console: Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://servername//rest/viewIssue/1/remoteIssueLink/render/10001

This widget could not be displayed.

Before running around checking all sorts of things and editing xml files, please check the base urls for both applications, had the same problem and that is how I resolved it.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

106 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you