Cannot connect to UPM server

Hi

We recently upgraded JIRA from 4.4.4 to 5.0.6 and are currently looking into upgrading to 5.1. Since the upgrade the UPM has worked fine until recently when it has stopped working.

We are currently using UPM 2.4.1 with JIRA 5.0.6. I have confirmed that the server can connect to the marketplace and can also ping that IP address successfully.

However in our log files we see this error message:

2012-07-13 10:41:25,128 http-49150-9 WARN amallinson 641x1911x1 f9gcbw 81.149.23.191 /rest/plugins/1.0/pending/d2887a26-8680-4348-a7be-8826b1e0dc62 upm.notification.cache.NotificationCacheUpdaterImpl Automatic plugin update check failed

com.atlassian.plugins.PacException: 404

Repeated at random intervals.

When we go to the manage plugin's page we just get the following message displayed:

The Atlassian Marketplace server is not reachable. To avoid problems when loading this page, you can disable the connection to the Marketplace server. Click here for more information...

However we can still update plugins and we can also still use the find new plugins page without problems.

3 answers

1 accepted

It was a bug. Upgrading JIRA to 5.0.7 solved it for us. Maybe you should try this.

Cheers,
Dom

Yeah Atlassian just confirmed as a bug in 5.0.6

0 votes
David Simpson Community Champion Jul 12, 2012

Does this happen regularly?

It may just be that you are having networking issues reaching Marketplace from time to time.

Everytime i have opened the UPM it appears but yet i can still use the UPM to upgrade plugins using it as well as installing new plugins too.

Same problem here. This only affects our JIRA installations, Confluence with UPM 2.4.1 works flawlessly. Any hints?

I am getting these messages as well.

Same here, although it's a test system, and I was happily blaming other teams doing some unrelated testing on the network. I will have another look when they've finished. Our symptoms include clicking "upgrade" or "install" and the page just churning and appearing to do nothing, although when you refresh, the change has been completed. It's like the UPM connects ok, does the job, loses the connection (with a similar message to the above) and hence never goes to the "ok, I'm done, tell the user" process.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,878 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot