Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,342
Community Members
 
Community Events
168
Community Groups

Can't edit the reporter field on a project

A lot of user from our space, can't edit the reporter filed on the ticket of an specific project, even though I and other users are in the administrators group, we can't edit the field.

3 answers

1 accepted

4 votes
Answer accepted

Hello,

Did you check who has the permission to modify reporter on your project?

Selection_300.png

Also reporter field should be present on edit screen, too.

Regards.

Yes, apparently no one can, it's really weird since I can do that in other projects but not even the one that created the project can, is like some kind of bug.

But who has the project permission for modify reporter?  Can you check the permission shown for that project as @Elifcan Cakmak has shown?

From what I was told just now, everyone that has administrator group could do it two weeks ago but now, no one can. You can see that in here Permissions.jpg

Hi,

Roles are groups are different things. In your project, project role administrators has the permission to modify reporter. You can see who are in this role on People tab on the left.

Also as I said earlier, reporter field should be on the edit screen of your project. Maybe someone removed it since then?

Regards.

Like # people like this

Hi, I was trying to add the reporter field in the edit screen, but it's still not working

Ok, it's on screen, so the next two questions are:

  • Are you using that screen for issue edit?
  • Do you have the project rights to edit the reporter?  (Are you in one of the two roles in the project that have the right in your screenshot?)

Yesterday, I tried to modify the reporter field when I added all the roles in the project, and it didn't work, but I changed the "Edit Screen" as well and even yesterday didn't work, today it worked, perfectly. Thank you for you help to both of you.

This helped me too - the edit screen didn't have 'reporter' field in it, even though it shows on the screen.  Adding it made it immediately possible to edit reporter after an F5.

Like # people like this

I faced the same issue and this was the solution. Reporter can be seen on the "screen" even if it's not assigned to the screen and therefore it can't be edited :)

However, for me, it doesn't make sense that the field is shown on the edit issue screen even if it is NOT assigned to the screen. Should it be like this? Well, it's another discussion and doesn't belong to this topic.

When in the said project, click on project settings and then on people. Check there if you are added as admins to the said project, if not, add yourself and whoever need to be admins in the project. That worked for me.

This is the best most straight forward answer. Thanks!

Like Josh Simnitt likes this

Except that you probably don't want to make everyone a project admin!

Like Josh Simnitt likes this

@Nic Brough _Adaptavist_ Is there a way to allow non-project admins to set the Reporter on an issue??

As discussed in the conversation following the answer, look at the permission scheme.

Like Geetha likes this

If the user have modify reporter permission then he can edit the reporter even though he is not a project admin?? Is it possible 

Thanks a lot! it helps me too...Cheers!

Suggest an answer

Log in or Sign up to answer