Application Link: Not able to recreate existing application link

Hi,

I had a problem with application link between JIRA 5.2.11 and Confluence 5.4.4.

Consequently, I tried to recreate app links but in the last step of application link, the error message appears: "Internal error ..." and I was not able to finish setting of application link.

My colleague tried to recreate app links and it worked ...

My colleague and me have same profile in JIRA and Confluence (admin account)

We checked jira-log and we found this warning: " 2014-09-15 09:23:12,892 http-bio-80-exec-102 WARN p-Cedric.Devaux 563x12764x1 1h69ubr 10.101.140.19 /plugins/servlet/applinks/listApplicationLinks [atlassian.applinks.ui.BatchedJSONi18NBuilderFactory] Duplicate i18n entry for key 'applinks.auth.provider.com.atlassian.applinks.api.auth.types.OAuthAuthenticationProvider'"

I suppose the problem comes from my account.

Some one can help me?

 

Thank you

 

3 answers

This widget could not be displayed.

Hi Cedric, I've seen similar cases where the problem was that the user that was creating the application link wasn't authenticated in both applications (websudo) and during the application link creation the authentication is required and for some reason the authentication isn't performed successfully.

If it happened only once, it's possible that it was just an authentication issue, like browser using old cookies.

Cheers

Hi Tiago, I delete cookies but the problem persist. Thank you for your help.

This widget could not be displayed.

Hi Cedric,

From this message it seems that there is actually something left in the database from the old Application Link, which is stopping you from creating a new one.

I'd suggest you to give a try to the steps proposed in this document, looking for the old link with Confluence and removing it directly in JIRA's database. After deleting it, try to create the Application Link again. Please attend to have a backup of your database before modifying it.

Regards,

Gustavo Refosco

Hi Gustavo, I'll try this

This widget could not be displayed.

Hi, The log message: Duplicate i18n entry for key 'applinks.auth.provider.com.atlassian.applinks.api.auth.types.OAuthAuthenticationProvider'" Is just to do with generating UI text it wont affect the operation of AppLinks. It is difficult to diagnose your issue without some additional info, e.g. which screen the error occurred on. The AppLinks creation process goes through 8 distinct steps. On the Local Instance 1. The local instance reads configuration form the remote instance and asks the user for confirmation 2. The local instance sets up incoming configuration 3. The user is redirected to the remote instance On the remote instance 4. The remote instance reads configuration from the local instance and asks the user for confirmation 5. The remote instance sets up incoming configuration 6. The remote instance sets up outgoing configuration 7. The user is redirected back to the local instance On the local instance 8. The local instance sets up outgoing configuration Are you able to determine roughly where in that process your error occurs? Is it in the local or remote instance,is it before or after you are asked to confirm creation of the link?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

145 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you