Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,195
Community Members
 
Community Events
165
Community Groups

Adding a component which has a space in the it through the importer

Hi all,

 

I'm using the importer to add some test cases into JIRA, but when I add a component to the test cases which has a space in the component name (example 'upgrade project') I get an invalid component error back and so I'm having to leave the component out and then mass update the test cases afterwards.

I've tried to use different methods to show it as one word instead of a separate component such as speak marks, apostrophes, underscores, even wild card items such as enclosing it in percentages etc... but so far to no avail.

Does anyone know if its possible to add a component through the importer which would have a space in it?

thanks all in advance

 

2 answers

1 accepted

0 votes
Answer accepted
Andy Rusnak Atlassian Team May 12, 2022

Hi Samuel, 

Welcome to the Atlassian Community!  I am sorry to hear about the issue you are experiencing regarding your issue imports.  Just to confirm the steps you are taking when running into the issue: 

  1. (Gear Icon) > System > Import > External System Import
  2. Choose the project to import into
  3. Choose CSV and map the field values from the CSV to the field values in the issue
  4. Begin the import

I just ran a quick test using a component with a space in it and does look to have imported for me.  So I am want to make sure I am taking the same steps you are in trying to replicate the issue.  

Could you also potential post here the header you have in your CSV file, along with maybe a sample line or two?  

Best, 

Andy

Hi Andy,

thank you for getting back to me, it looks like I've made a mistake, the importer we are using is part of the Zephyr plugin, I apologise for the error, I will ask this question on their board.

 

Thanks

Sam

Andy Rusnak Atlassian Team May 17, 2022

Hi Sam, 

Thanks for the additional information.  And no need to apologize at all.  If there anything I can do to assist please feel free to reply back on this thread.  Best of luck in the continued troubleshooting! 

Take care, 

Andy

0 votes

Hi All,

I'm also observing an issue similar to this. I have imported excel file that has space in component field. E.g. Component in Zephyr is "my doc". While I'm trying to add my doc in excel sheet it fails to import data. I have tried different things but still not luck. e.g. "my doc", my_doc, my doc, 'my doc' etc

Please suggest any solution?

Thanks all in advance!

 

TC,

Asad

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you