custom field not available in field layout

I created a new text custom field (single line) and I am trying to make this as mandatory under a specific field layout configuration but it is not available in the list of fields. Why is that? Under what conditions a field is not available?

 

secure/admin/ConfigureCustomField!default.jspa?customFieldId=xxxxxx

1 answer

This widget could not be displayed.

None - custom fields should all be listed on the field configurations.

The only thing I can think of (and I've not tested this, and it doesn't feel right) is indexing.  Do you have a searcher set for the field?  Also, after adding it, have you re-indexed?

Hi Nic,

I have not re-index after adding the new custom field. What is strange is that at the same time I added 3 custom fields (1 text single line, 1 user picker and 1 checkboxes field). Without re-index the database the 2 fields are coming up to the field layout and I manage to set them as mandatory but the text field is not showing. All 3 fields have the default searchers.

Ok, can you try a full re-index?

A full reindex did not resolve the problem.

I resolve my issue by deleting this missing text field and then create a new one (type URL). This one is available under my layout configuration.

Can someone help me to identify the source code which is responsible to load custom fields on a View Field Configuration?

The problem is still there for different other custom fields we have. In my current case is not an option to delete and add again the custom field as it is an old field and it is been used in several other projects.

I have noticed that those custom field with the problem do not appear in all the field configurations I have in the system. If it is worth mentioning our data were migrated from JIRA v 4.0.2 -> 4.4.5 -> 6.4.7 last year.

There's something very wrong with your installation here.  A field configuration lists all fields you've got in the system, unless the field type is explicitly coded to be non-visible.

What, exactly, is the field type of the missing fields?

Thanks Nic

I have seen the problem with different types. Select List (single choice) is my current problem but I have in the past similar case with a Text Field (single line) field.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

172 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you