Why are transitions missing and the status wrong

Have an issue that I hope someone has a fix for.

I created a project and many issues within it. I then imported updates to these issues and included in this import was the status.  Now on many of them the transition buttons are missing.

Also I have tasks that the status is wrong for. This comes about in the fact that before the import it was on status of 1 but in my import I had it update to status 2.  On screen it reads that it is on status 2 just as I have imported but the transition buttons (if there is one) will be for a transition coming of status 4.  When I look at the Transitions activity it says that the issue is on status 1.

I have tried a re-index but no change.  In short the project looks to be all stuffed up. Given it is a project that we are well into I am not looking for a solution of start again.

 

PLEASE HELP.  Thanks,

3 answers

0 vote

Very quick thing to try - admin -> integrity checker

Does that report any problems?

Hi,  I did and it did return errors within the workflow for about 6 out of the 1000's of issues. These were for issues I updated the status for that did not have that status in their workflow. In the example above this is not one of these tickets. All other results passed. 

0 vote

Ok, let's look at a single issue that is broken (I'm assuming the others are similar)

Can you look at the issue view and tell us

  • What the status is
  • Give us the workflow diagram
  • Tell us what transitions there are available in the workflow bar at the top

Also, can you run a few searches for us.  They need to be similar and ideally short, and should select for the issue we're looking for on things not related to status (so "project = X and summary ~ "this issue" and updated > -7d" might be a start).  Once you've designed a good search like that, try it with these clauses added:

  • and status = 1
  • and status = 2
  • and status = 4

Which one, if any, of these, finds your issue?

Nic thanks for your comment on this. In the end I ended up fixing them as I found them.  Looks like the issue is with importing and updating an issue type. I had another project that I updated via CSV and for every issue I changed the type of I needed to go and fix them by moving them within JIRA to another type and then back again. 

Just wanted to say that I appreciated your efforts on this and not have them go unnoticed. 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 6 hours ago in Hipchat

Moving from Hipchat to Stride? Here’s what you’ll love

Heya, Hipchat friends! We’re so happy you’re checking out   Stride. Whether you know it or not, you have been instrumental in making Stride come to life. Every feature, design, and functionality...

29 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you