Problem with CheckList-AddOn (Items will sometimes not be shown)

Dear SupportTeam,

we are using at the moment Jira v7.2.3 with the Checklist-AddOn v3.1.5 and observed that the checklist is sometimes not working correct. The checklist will not expand and the items wont be shown.

There are only the words (as a link) "show more" that can be read but nothing will happend if u will click this link.

The checklist-items will be be shown if u click beside this link (right or left), but not on the left "edit"-button.

If u click on the edit-button the defined items will be shown as expected in the edit-mode. If u leave the edit-mode by "cancle", the items will be hidden again.

But if u leave the edit-mode by "ok/apply" the items will be displayed.

This behaviour is very strange and many users are dissatisfied with it. The expected behaviour is, that the checklist-items will be shown automatically.

Is this problem already known? And if yes ... have u got a solution for it?

 

Thanks for your reply

Best regards

 

6 answers

This widget could not be displayed.

Hi,

I would require more information to troubleshoot the issue.

  • Which browser are you using?
  • Is it possible to record the screen if you can reproduce the issue. It helps me understand what the user is doing and allows me to replicate the procedure.
  • Do you get any browser errors when this happen?
  • Did you recently upgrade JIRA and were using Checklist in an older version. It might be that a new JIRA version has introduced unexpected behavior for the plugin. 

Regards,

Yves

 

This widget could not be displayed.

Hi Yves,

first i like to show u what we are doing. We can replicate this behaviour easy . It happends every time, if we open an issue of a project the first time. The items of the defined checkbox will not be shown at the first time. The items will only be shown it the user make some more action. These action can be one of the follow:

  • open the issue again
  • click on the left or right side of the "show more"-link
  • enter the edit-mode by the edit-button and leave the edit-mode by the "apply/ok"-button

Take a look of this small movie please, i demonstrate it there.

We dont get any browser errors and we are using the follow browsers:

  • IE 11.672.10586.0
  • Edge 25.10586.672.0
  • Firefox 49.0.2

And yes, we migrated JIRA to a new server and we upgraded JIRA during this process. The old versions were JIRA 7.1.9 build: 71013 with the Checklist-Addon Version 3.1.3.

I hope i could give u the informations that u need.

Best Regards

Hi Helmut,

Thanks for the supplemental information! The movie showed me what I suspected. It looks like Checklist doesn't get the signal from JIRA that the customfield has been loaded and as such is not properly initialized. I think that it is because of the view you are in. Is that the search view? In order for me to troubleshoot it, I need to be able to reproduce the view.

Before the upgrade to 7.2.3, was it functioning properly?

Thank you!

Yves

This widget could not be displayed.

Hi Yves,

yes it was working properly on the old server under jira 7.1.9 and checklist 3.1.3. But the checklist version 3.1.3 is not compatible with the new JIRA version 7.2.3 ... thats the reason, why we upgraded also the checklist to v 3.1.5.

 

And what do u mean with "search view"? I open the project direct by using the menue-item "projects". 

  1.png

 

The behaviour is also the same, if i open the project by main-menue -> issues -> Search for issues.

2.png

 

And i dont know if its helpfull, but maybe ... so thats the checklist-configuration

config_param.png

Hi Helmut,

Thanks for the additional info. I will investigate more and give you feedback. It seems that Atlassian changed how it dispatches its events in the new version. Hopefully I will be able to rehook the plugin properly.

 

Yves 

This widget could not be displayed.

Hi Helmut,

Please try version 3.1.7. It should now be working. If not, please let me know and thank you very much for reporting the issue.

Regards,

Yves

Hi Yves,

i like to confirm u that this issue is fixed with the new version 3.1.7.

Thank u very much for the fast and great support! smile

 

Best Regards

 

This widget could not be displayed.

Hi Yves,

i´m sorry but i need to inform u that we have another problem now. The problem is that the browser will crash totaly (freeze) if we try to edit the checklists. The error happends often but we can not reproduce the error by doing exactly the same. Mostly it happends if we add an item. Sometimes it happends after, sometimes before adding the first item ...and the other time it happends if we add the second item...

The problem can easy reproduced for the follow browsers:

Edge 25.10586.672.0

IE 11.672.10586.0

It seems that Firefox (49.0.2) is working properly

I have also here some links for u´re demonstration:

Edge1

Edge2

IE

 

Best Regards

Hi Helmut,

I will investigate the issue. Sorry for the inconvenience.

Yves

Hi Yves,

i dont know if its helpfull for u ... but maybe... so i´d like to inform u about that we recognized also a way to get firefox crashed (in reference to the check-list-problem).

The result is not so fatal like for ie- or edge-browser ... because the firefox doesnt crash totaly ... firefox detect that there is a problem with the website and we are able to stop this site.

The follow video demonstrate what we are doing.

 

Best Regards

Knut (by order of Helmut)

Hi Helmut, Knut,

I have sent you a beta version of the add-on to validate if it fixes the problem on your side.

Yves

Hi Yves,

i didn`t received your beta-version yet. how did u sent it to me? can u sent it again or upload it and send me an download-link for it please?!

-Knut (by order of Helmut)

 

I have sent it to the email address you left when purchasing the add-on. May it was spammed because of the attachment. I have sent you another email. If you don't receive anything still, contact me via the email on this page.

Yves

This widget could not be displayed.

Hello,

The same seems to be happening to us. Was there a solution found for it?

Can you please post an update of the situtation?

 

Thank you!

Hi Cristina,

These enhancements were pushed to the add-on in subsequent releases.  I'm looking into what may have changed.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

143 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you