Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why is my "Filter Subscription" returning a different result?

Hi 

I recently found an issue with the filters that I have subscribed myself to.

Filter using: 
Filter_Result.PNG

This return 29 items if I search it using the above filter.

But if I add a subscription to the filter it return inconsistent results sometimes I would get 1 item and sometimes 3 items via the email.

Filter_Subscription_Results.PNG



I have tried different filters as well same thing happened again. e.g. I was expecting 184 items but get 168 via email when I subscribe to the filter.

Most people would not see the problem because they wouldn't check the filter in jira again to make sure that the items they received via email matches the item you have in jira. I have also checked in case it was returning a different filter but that's not the case.

Not sure if anyone else has seen this issue before? I would appreciate any feedback.


JIRA instance details:
JIRA standalone Server version 8.02, only using jira core.

2 answers

0 votes
John Funk Community Leader Feb 08, 2021

Hi @farkhnawaz  - Welcome to the Atlassian Community!

That is very strange behavior. I would go ahead and submit a support ticket to Atlassian here:

https://support.atlassian.com/contact/#/

Please post back here with the resolution. 

Hi 

I have raised a support ticket thanks.

Hi John,

found the fix for it. 

By doing a full re-index I was receiving the correct number of issues via email.

  • Navigate to Jira administration (Cogwheel Icon) > System.
  • Select Indexing under Advanced.
  • Choose full-reindex
  • Click on Re-index.
Like John Funk likes this
John Funk Community Leader Feb 10, 2021

Ah, the dreaded re-index, haha. I use Cloud so I forget about having to do the re-index with server. Glad you got your fix.

0 votes
Daniel Ebers Community Leader Feb 08, 2021

I saw cases in the past when the subscribing user is not able to see the full set due to "Issue Security" (Security Level set).
This, however would imply there is a different user involved. When person X is executing a filter and same person is subscribed to a filter it should show the same results, indeed.

The issue subscription currently shows 1 issue - from your screenshot but the filter gives back 29 results.
Can you in first step compare what is different with the 28 vs. the 1 issue?

Hi @Daniel Ebers 

I have compared it and they have the same information based on the filter query. Also each time I run the subscription manually it gives me different items via email.

Kind regards,
Farkhnawaz

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

300 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you