Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,369,970
Community Members
 
Community Events
168
Community Groups

Default value for Summary field not working

Recently upgraded JIRA version from 7.5.3  to JIRA 8.13.4. 

I have set the default value for summary field in Field configurations using a script as below

<script type="text/javascript">
if (document.getElementById("summary").value == "") {
document.getElementById("summary").value = "XXXX";
}
</script>

After the upgradation , the above workaround is not working to set the default value for Summary field . Please advise 

 

2 answers

2 accepted

1 vote
Answer accepted

Hi , thanks for the response .

It got resolved when I set Enable HTML in project description option ON in System Info.

After the upgrade , automatically it got set to OFF , i think we should manually set to ON.

1 vote
Answer accepted
Brant Schroeder Community Leader Mar 10, 2021

@Anita Narayanaswamy 

That is the correct JavaScript, is it placed in the fields description?  I am assuming it was not changed.  I wonder if it could be a cache issue in the browser.  I would double check everything here: https://confluence.atlassian.com/jirakb/how-to-set-default-value-for-summary-field-in-jira-800692650.html#:~:text=Go%20to%20the%20respective%20Field,Click%20on%20Edit.&text=Replace%20%3CDefault%20Value%20for%20Summary,for%20the%20Issue%20Summary%20field.

After you confirm that it is setup properly please clear your browsers cache and try again.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS

Atlassian Community Events