Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,198
Community Members
 
Community Events
176
Community Groups

Database: JIRA couldn't connect to your database MSSQL

I have gone through a bunch of different articles and troubleshooting and can't find a way to resolve this.

I have restored from backups which I thought would fix the issue but even when putting the DB and Jira server back to a state last week the error comes up.

I have tried messing with the JVM cert store, the server cert stores, checked networking and am able to ping from both ends and telnet to the sql instance port.

I have chacked the jira database path and account and ensured everything matched in the dbconfig file.

 

I am really at a lose as this system stopped working randomly

 

below are the logs that seem relevant...

 

2019-04-21 10:12:38,415 localhost-startStop-2 INFO      [c.a.jira.startup.DefaultJiraLauncher] Stopping launchers
2019-04-21 10:12:38,415 localhost-startStop-2 ERROR      [o.a.c.c.C.[Catalina].[localhost].[/]] Exception sending context destroyed event to listener instance of class [com.atlassian.jira.startup.LauncherContextListener]
java.lang.NullPointerException
 at com.atlassian.jira.startup.ClusteringLauncher.stop(ClusteringLauncher.java:46)
 at com.atlassian.jira.startup.DefaultJiraLauncher.stop(DefaultJiraLauncher.java:197)
 at com.atlassian.jira.startup.LauncherContextListener.contextDestroyed(LauncherContextListener.java:211)
 at org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:4839)
 at org.apache.catalina.core.StandardContext.stopInternal(StandardContext.java:5478)
 ... 3 filtered
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
 at java.lang.Thread.run(Thread.java:748)
2019-04-21 10:13:21,150 localhost-startStop-1 INFO      [c.a.jira.startup.JiraHomeStartupCheck] The jira.home directory 'E:\Program Files\Atlassian\Application Data\JIRA' is validated and locked for exclusive use by this instance.
2019-04-21 10:13:21,275 localhost-startStop-1 WARN      [o.a.catalina.util.SessionIdGeneratorBase] Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [125] milliseconds.
2019-04-21 10:13:21,338 JIRA-Bootstrap INFO      [c.a.jira.startup.JiraStartupLogger]
   
    ****************
    JIRA starting...
    ****************
   
2019-04-21 10:13:21,463 JIRA-Bootstrap INFO      [c.a.jira.startup.JiraStartupLogger]
   
    ___ Environment _____________________________
   
         JIRA Build                                    : 7.13.1#713001-sha1:5e06076c2d215a6f699b7e5c90ab2fae7ba5a1ce
         Build Date                                    : Tue Jan 29 00:00:00 EST 2019
         JIRA Installation Type                        : Standalone
         Application Server                            : Apache Tomcat/8.5.32 - Servlet API 3.1
         Java Version                                  : 1.8.0_181 - Oracle Corporation
         Current Working Directory                     : E:\Program Files\Atlassian\JIRA
         Maximum Allowable Memory                      : 5333MB
         Total Memory                                  : 958MB
         Free Memory                                   : 921MB
         Used Memory                                   : 37MB
         Memory Pool: Code Cache                       : Code Cache: init = 104857600(102400K) used = 11480128(11211K) committed = 104857600(102400K) max = 1048576000(1024000K)
         Memory Pool: Metaspace                        : Metaspace: init = 0(0K) used = 21721960(21212K) committed = 22462464(21936K) max = -1(-1K)
         Memory Pool: Compressed Class Space           : Compressed Class Space: init = 0(0K) used = 2549792(2490K) committed = 2801664(2736K) max = 1073741824(1048576K)
         Memory Pool: PS Eden Space                    : PS Eden Space: init = 262144000(256000K) used = 18994512(18549K) committed = 262144000(256000K) max = 2026897408(1979392K)
         Memory Pool: PS Survivor Space                : PS Survivor Space: init = 43515904(42496K) used = 0(0K) committed = 43515904(42496K) max = 43515904(42496K)
         Memory Pool: PS Old Gen                       : PS Old Gen: init = 699400192(683008K) used = 21584504(21078K) committed = 699400192(683008K) max = 4194304000(4096000K)
         JVM Input Arguments                           : -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -XX:-OmitStackTraceInFastThrow -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+PrintGCCause -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=20M -Xloggc:E:\Program Files\Atlassian\JIRA\logs\atlassian-jira-gc-%t.log -XX:InitialCodeCacheSize=100m -XX:ReservedCodeCacheSize=1000m -Dcatalina.home=E:\Program Files\Atlassian\JIRA -Dcatalina.base=E:\Program Files\Atlassian\JIRA -Dignore.endorsed.dirs=E:\Program Files\Atlassian\JIRA\endorsed -Djava.io.tmpdir=E:\Program Files\Atlassian\JIRA\temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=E:\Program Files\Atlassian\JIRA\conf\logging.properties exit abort -Xms1000m -Xmx6000m
         Java Compatibility Information                : JIRA version = 7.13.1, Java Version = 1.8.0_181
2019-04-21 10:13:21,822 JIRA-Bootstrap INFO      [c.a.j.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from E:\Program Files\Atlassian\Application Data\JIRA\dbconfig.xml
2019-04-21 10:13:22,338 JIRA-Bootstrap ERROR      [c.a.config.bootstrap.DefaultAtlassianBootstrapManager] Could not successfully test your database:
com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: "java.security.cert.CertificateException: Certificates do not conform to algorithm constraints". ClientConnectionId:e7c054a2-231f-4423-9cc3-cf5e15155549
 at com.microsoft.sqlserver.jdbc.SQLServerConnection.terminate(SQLServerConnection.java:2435)
 at com.microsoft.sqlserver.jdbc.TDSChannel.enableSSL(IOBuffer.java:1816)
 at com.microsoft.sqlserver.jdbc.SQLServerConnection.connectHelper(SQLServerConnection.java:2022)
 at com.microsoft.sqlserver.jdbc.SQLServerConnection.login(SQLServerConnection.java:1687)
 at com.microsoft.sqlserver.jdbc.SQLServerConnection.connectInternal(SQLServerConnection.java:1528)
 at com.microsoft.sqlserver.jdbc.SQLServerConnection.connect(SQLServerConnection.java:866)
 at com.microsoft.sqlserver.jdbc.SQLServerDriver.connect(SQLServerDriver.java:569)
 at java.sql.DriverManager.getConnection(DriverManager.java:664)
 at java.sql.DriverManager.getConnection(DriverManager.java:247)
 at com.atlassian.config.bootstrap.DefaultAtlassianBootstrapManager.getTestDatabaseConnection(DefaultAtlassianBootstrapManager.java:347)
 at com.atlassian.jira.config.database.JdbcDatasource.getConnection(JdbcDatasource.java:211)
 at com.atlassian.jira.config.database.DatabaseConfig.testConnection(DatabaseConfig.java:88)
 at com.atlassian.jira.health.checks.DbConfigurationAndConnectionCheck.doPerform(DbConfigurationAndConnectionCheck.java:60)
 at com.atlassian.jira.health.HealthCheckTemplate.perform(HealthCheckTemplate.java:23)
 at com.atlassian.jira.health.DefaultHealthCheckExecutor.runCheck(DefaultHealthCheckExecutor.java:74)
 at com.atlassian.jira.health.DefaultHealthCheckExecutor.lambda$applyAndCollectExceptions$1(DefaultHealthCheckExecutor.java:53)
 at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:184)
 at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:175)
 at java.util.Iterator.forEachRemaining(Iterator.java:116)
 at java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1801)
 at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
 at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
 at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:151)
 at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:174)
 at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
 at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:418)
 at com.atlassian.jira.health.DefaultHealthCheckExecutor.applyAndCollectExceptions(DefaultHealthCheckExecutor.java:53)
 at com.atlassian.jira.health.DefaultHealthCheckExecutor.performHealthChecks(DefaultHealthCheckExecutor.java:42)
 at com.atlassian.jira.health.HealthChecks.executeChecksAndRecordResults(HealthChecks.java:164)
 at com.atlassian.jira.health.HealthChecks.runHealthChecks(HealthChecks.java:154)
 at com.atlassian.jira.health.HealthChecks.runHealthChecks(HealthChecks.java:66)
 at com.atlassian.jira.startup.BootstrapContainerLauncher.start(BootstrapContainerLauncher.java:48)
 at com.atlassian.jira.startup.DefaultJiraLauncher.preDbLaunch(DefaultJiraLauncher.java:115)
 at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:101)
 at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31)
 at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:100)
 at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:154)
 at java.lang.Thread.run(Thread.java:748)
Caused by: javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: Certificates do not conform to algorithm constraints
 at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
 at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1964)
 at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:328)
 at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:322)
 at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1614)

2 answers

0 votes

Hey Brandon,

looks like https://codetitans.pl/blog/post/datagrip-connect-to-ms-sql May be relevant in your case (maybe not).

 

CCM

That’s a good one. I found it earlier this evening a gave it a try but no dice. At this point I’ve emailed my user base to expect jira services offline Monday morning and to resort to using email until resolved... 

did you ever figure out what the issue was and how to correct.  We are having this same issue now

Fadoua Community Leader Apr 21, 2019

BTW is this your Production Server?

Yes this is our production server.

Yes I tried the ssl algorithm constraints check article 

Fadoua Community Leader Apr 21, 2019

please open a high priority ticket with Atlassian Support since this issue is affecting your production server. Click here

Best,

Fadoua

I opened a ticket but cant find the SEN because the server is in an errored state could I pull it from a table in sql or is it in a file on the jira server?

Fadoua Community Leader Apr 21, 2019

@Brandon Rogers 

Try to access my.atlassian.com, you will be able to find the SEN for your JIRA Core or Software.

Best,

Fadoua

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events