Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,409,328
Community Members
 
Community Events
169
Community Groups

Does the Atlassian Community block JSON in replies?

Rob Horan Community Leader Nov 19, 2020

Several days ago I asked a question of the community about a particular issue I was having with an automation rule.  I worked with someone offline and was able to obtain a solution.  I then tried to post an answer to my own question.  It would not post.  I tried in a code block, outside of a code block - NOTHING.  I then posted my solution as an image.  That was fine.

Is there a block against JSON?  This would be unfortunate as it would prevent others from getting the help they need in many cases.

1 answer

1 vote
Daniel Ebers Community Leader Nov 20, 2020

Hi Rob,

I think it is not especially because of JSON format and experienced the same when HTML tags were in the content to be copied here.

The answer is saved after clicking on "Answer" but magically "gone" - not displayed. No chance to recover it.

Did you copy the JSON from a really plain source - or was there some HTML in it maybe (or some other formatting)?
Up to now I thought it would be a local problem on my browser/PC.

Regards,
Daniel

Rob Horan Community Leader Nov 22, 2020

 

I copied from a plain text editor.

Even if I did have some HTML, I also pasted into a code block, which should have ensured success, but to no avail.

Daniel Ebers Community Leader Nov 22, 2020

Could you please paste the problematic JSON here into reply again?

If it still fails I provide you a mail address so this can be looked into by the responsible people.

Rob Horan Community Leader Nov 23, 2020

{
"fields": {
"parent": {
"key": "{{issue.parent.key}}"
}
}
}

Rob Horan Community Leader Nov 23, 2020

image (7).png

Got it. Looks ok for now.
Except for the indent, maybe :)

Rob Horan Community Leader Nov 23, 2020

Except that when I went to paste exactly that on my question again it failed.

Daniel Ebers Community Leader Nov 23, 2020

If you want you can send it exactly in the troubling format to this temporary mail address:

AgreeableHyena@maildrop.cc

I cannot copy it out from the picture for a test.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events