confluence jira macro timeout

Hi

we use Confluence 5.5, JIRA Macros 5.5.4 and JIRA 6.3.10

In the Confluence configuration we set the timeout values to zero (should be interpreted as an infinite timeout - see https://confluence.atlassian.com/display/DOC/Configuring+HTTP+Timeout+Settings)

During a comlex search the JIRA macro terminates after 10 sec. with the following error: com.atlassian.confluence.macro.MacroExecutionException: java.net.SocketTimeoutException: Read timed out

Is there a additional timeout in the "JIRA Macro"? If jes, how can I increase it?

 

Regards,
Uli

2 answers

1 accepted

1 vote
Accepted answer

Strange, what happens if you manually set to 180000(3 minutes)?

The idea is to address to address the timeout problem, then we can further check if the zero not using infinite is is some kind of BUG.

Thanks and Regards,
David| The Engineer that like Windows for realsies.

Hi Deividi, Thanks for the reply. I already tried with 20000 ( 20 sec.) The timeout occured after 10 sec. - strange isn't it? Regards, Uli

Yeap, in that case I would advise you to raise a case to our JIRA support team at https://support.atlassian.com, since we would need to check logs to further understand what is happening.

OK, we have raised a support case. Thanks for your help. I mark this question as answered. Regards, Uli

Hi Ulrich, how long does it take for this request to return for you: <JIRAbaseURL>/rest/api/2/issue/createmeta?projects.issuetypes? I'm looking into the same problem for another customer, so please feel to let me know your Support ticket reference and I'll give it a review for you. Cheers, Lachlan

Hi Lachlan the support ticket ref. is CSP-139374 Cheers, Uli

1 vote

Hi Ulrich, please try the workaround in https://jira.atlassian.com/browse/CONF-36316 and let me know if this helps smile

Hi Lachlan, thanks for the information. I think this will be practicable workaround for us. We will test ist and I come back when we have some results. Cheers, Uli

Hi Uli, just a heads up that this workaround may still fail if the call to the projects endpoint in JIRA takes more than 10 seconds, as it appears there is a separate default time out in use. I'm still investigating if/how this can be overridden, and will update the bug report when I know more.

Hi Uli, here's a second bug that might be causing the issue: https://jira.atlassian.com/browse/CONF-36335

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

62 views 3 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you