Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,520
Community Members
 
Community Events
168
Community Groups

cannot copy page

Neither space administrators nor system administrators can copy pages, neither independent pages nor parent pages that contain child pages.

image.png

I hope I can get help, thanks

Amin

2020.12.28

2 answers

1 accepted

0 votes
Answer accepted
Daniel Ebers Community Leader Dec 28, 2020

Hi Amin,

that looks strange but did you make sure you have the create pages permission?
https://confluence.atlassian.com/doc/copy-a-page-139013.html

Also this checkboxes are not there if there are no child pages and/or no attachments to the page.

Can you confirm both is present in the space you are seeing?

Regards,
Daniel

Hi,Daniel Ebers

thank you for your reply.

As shown 1-1, can’t select multiple pages here?

image.png

(1-1)

 

The following are the problems I encountered

As shown 1-2,single page and contains pictures,It can be checked.

1.png

(1-2)

 

As shown 1-3,I want to choose to copy this parent page and include all the following child pages.Parent page does not contains pictures,It cannot be checked.

2.png

(1-3)

The above is my confusion.

thanks.

Daniel Ebers Community Leader Dec 28, 2020

From what I understand it refers to "attached" pictures, not to ones that are embedded in a page. So this greyed out checkbox just suggests there are no attachments to be copied.

sorry. I didn't make myself clear. I hope that when I copy the page, I can copy the pictures contained in it with the attachments.

Daniel Ebers Community Leader Jan 06, 2021

I have re-checked now on my Confluence instance.

  • For a page with child pages it allows to "Include child pages". In case there is at least one attachment it also allows to "Include attached files and images". Otherwise this option is greyed out.
  • For a page with no child pages the option to "Include child pages" in greyed out. In case there is at least one attachment it also allows to "Include attached files and images". Otherwise this option is greyed out.

As for your screenshots that translates to:
1-2 is a single page and according to your information it contains at least one attachment why the "Include attached files and images" checkbox is offered to be checked.

Screenshot 1-3 I interprete in a way that it is a parent page with child pages but no pictures why on "Include attached files and images" there is no checkbox offered to be checked but on "Include child pages" indeed there is.

In summary: I was able to reproduce your observations on my test instance but from what I now understood this is expected behaviour.
Please let Community know in case of further questions.

confluence.JPG

 

Hi confluence, I have a similar issue. 
May i please know what could be the issue here?

I have a similar issue, none of the users on our instance can copy a page. The get the symbol that shows Confluence is processing the command but then after a while we get the same error as you have show above. I have tried different pages in different spaces with the same outcome. I am admin and have ensured create page permissions have been granted. I have resorted to exporting the page to a Microsoft .doc file then converting it to a .docx file and then importing it.

Daniel Ebers Community Leader Jul 23, 2022

For the error shown above I'd recommend to take a look into log files assuming it is a Confluence server (not cloud) because it differs from the initial effect the user observed.
If it does not help I would further suggest to open a new post here in Community.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
confluence.7.4.5
TAGS

Atlassian Community Events