Why does the name of a link to an in-page anchor change once I've saved it?

I've created anchors and links to those anchors on the same page in Confluence. I enter the link name in the Edit link>Advanced box, select Save, then test the link on the published page. When the link name is relatively short, the link works. If the link name is a little longer, it doesn't, so I go into edit mode on the page and go back to Edit link. For some reason, the link name has changed, which is why the link doesn't work on the published page. Here's an example:

I typed in #Constraints, saved, tested, went back in and my link name has changed to #Constrai

I made sure this wasn't a typo on my part (it isn't). What is happening?

0 answers

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

998 views 23 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you