Why are there no logs when attempting XML backup of Confluence

I do not seem to see any logs either in atlassian-confluence.log or in catalina.out when I attempt an XML backup of my Confluence instance.

I followed some steps in https://confluence.atlassian.com/display/DOC/Troubleshooting+failed+XML+site+backups and added the following lines to the log4j properties file :

log4j.logger.com.atlassian.confluence.importexport.impl.XMLDatabinder=DEBUG, confluencelog
log4j.additivity.com.atlassian.confluence.importexport.impl.XMLDatabinder=false

When I attempt an XML backup, I see an error 500 after a minute (presumably from Apache, I cannot directly access the Tomcat port due to firewall restrictions). However, there's no indication of any activity ongoing in the logs. I'm able to login to Confluence soon after and server seems to be doing ok.

Help..?

P.S : I'm running Confluence 5.1.3

2 answers

Just a quick check, did you reboot Confluence after the log4j changes?

@Colin: Thanks Colin, yes I did restart Confluence after the changes.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,022 views 14 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you