When using AD for authentication, users are not automatically added to confluence-users group

Although I have configured my AD connector to add users to the confluence-users group automatically when they login, this doesn't happen in all cases.

There are many, but the attached screenshot shows just one use as an example.

1 answer

1 accepted

In cases like that, I suggest you to check the logs to see errors related to membership.

Also check if the confluence-users group have the "Can Use" in Global Permissions.

Also if you have more then one directory set (e.g. Confluence Internal and LDAP), be sure that you don't have 2 users with the same username.

Hi Bruna,

It was because of 2 users with the same username.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Monday in Confluence

Calling all marketing teams who use Confluence - we want to hear from you!

Hi Community! me again 🙂 If you’re a marketing team using Confluence, we want to hear your story! How did you start using Confluence? What are your use cases? What have been some of the benefits?...

200 views 3 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you