Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to view PDF thumbnail in confluence

In conluence unable to preview the PDF thumbnail. People want to have thumbnail view for pdf files.

Please find the attached screenshot for your reference. The attached screenshot thumbnail shows preview for PPT file but doesn't for the PDF file.  

19 answers

This happened for me, when I copy the page with PDFs and all the thumbnails got removed.  I address this using the Atlassian Companion App with the default PDF view in Edge.

  1. Edit through Companion App
  2. Draw on the Page and the Erase it, so to enable Save Icon
  3. Upload
  4. Refresh page
  5. PDF thumbnails are back

I had a similar issue. Here is what I discovered:

1) When I printed PDF files from my browser and saved them, I was able to view the thumbnail in Confluence when previewing, no problems.

2) When I printed a PDF file of an email from Microsoft Outlook, I was not able to view the thumbnail in Confluence when previewing. Instead I was getting a suggestion to download Adobe Reader (I already have adobe reader).

How I fixed this:

I have both Adobe Acrobat DC and Adobe Reader on my PC. First I tried re-saving the file from Adobe DC and I didn't see any difference in Confluence after replacing the PDF file. I then opened the offending PDF file in Adobe Reader and re-saved the file. I attached the new PDF file to a page in Confluence and find that the preview of the file is now working as expected. There appears to be some kind of extra security on the file I printed from Microsoft Outlook.

Hi was there ever a solution to this please? We have thumbnail views working fine in our Service Desk but can't see them when working in Confluence. Using latest Confluence version, Windows and Google Chrome.

There are a few things at play here ... none of them specifically the fault of Confluence 

The experience I can tell is 

a) make sure you are NOT using Internet Explorer or Edge - they are not fully HTML5 compatible ... it exhibits itself "randomly", i.e. teh person next to you may not have any problems ...!!  Known Microsoft bug

 

b) check the source of your PDF ... I found the user in our system that was having trouble was using their photocopier to create a PDF but the file format metadata was a bit "off" so Confluence couldn't recognise it as a proper PDF and didn't know what to do with it.

We had to save the file to a PC, then open it with Acrobat and do a File Save As, then load the new file and it worked fine.

Hi Rodney, thanks for the quick reply!

I am using Google Chrome as mentioned. And I just tried the File > Save As trick in my Acrobat software and that didn't work unfortunately.

I'm thinking perhaps my issue falls into problems with the new editor rather than the pdf format as per the below reports:

https://community.atlassian.com/t5/Confluence-Cloud-questions/PDF-attachments-no-longer-show-a-thumbnail-of-the-first-page/qaq-p/1222391

https://community.atlassian.com/t5/Confluence-Cloud-questions/file-thumbnails-are-gone/qaq-p/1269241

 

And this issue:

https://jira.atlassian.com/browse/CONFCLOUD-67140

Thumbnails are in Application Data\Confluence\shared-home\dcl-thumbnail\

Permissions?

After logging all and poking around a bit more, I see that my issue is centered around a HibernateTemplate error:
execute Not closing pre-bound Hibernate Session after HibernateTemplate

This is occurring during a SQL query that is pulling file details on the thumbnail from the DB. Below is the SQL query that should be executed at that time:
select attachment0_.CONTENTID as CONTENTI1_12_0_, attachment0_.HIBERNATEVERSION as HIBERNAT2_12_0_, attachment0_.TITLE as TITLE4_12_0_, attachment0_.LOWERTITLE as LOWERTIT5_12_0_, attachment0_.VERSION as VERSION6_12_0_, attachment0_.CREATOR as CREATOR7_12_0_, attachment0_.CREATIONDATE as CREATION8_12_0_, attachment0_.LASTMODIFIER as LASTMODI9_12_0_, attachment0_.LASTMODDATE as LASTMOD10_12_0_, attachment0_.VERSIONCOMMENT as VERSION11_12_0_, attachment0_.PREVVER as PREVVER12_12_0_, attachment0_.CONTENT_STATUS as CONTENT13_12_0_, attachment0_.PAGEID as PAGEID14_12_0_, attachment0_.SPACEID as SPACEID15_12_0_ from CONTENT attachment0_ where attachment0_.CONTENTID=? and attachment0_.CONTENTTYPE='ATTACHMENT'

The issue I'm experiencing may be the same.  In Confluence 6.0.1 PDF thumbnails fail to load for all users except the first user created for this instance of Confluence.  The thumbnails either show up as a broken link or as it appeared in this thread's example, depending on the browser that I use.  Given that this works for the user that first created the wiki, I assume this is some sort of permission issue, but I've been unable to identify it.  When I follow the image location (not the link to the document, but the actual thumbnail's URL), I receive a Confluence "Page Not Found" error:

Page Not Found

The page you were trying to reach could not be found. This could be because:

  • The page does not exist.
  • The page exists, but you do not have permission to view it.

Same issue with Confluence 5.8.13, anyone found a solution?

 

I can assure you we have lots of PDF and Word documents that display directly as thumbnails

It looks like we can't display PDF/Word attachments in this forum as thumbnails - I just tried to load another test and it doesn't give the option of how to display it

But you might want to try downloading this PDF and try loading that to your system just to see if it is anything to do with your file

What happens when you try to load a Word document to your system?

what happens when you try to load your PDF here and show as thumbnail?

I have just tried to show your attachment here as thumbnail by selecting the link insert - all I get is a link display option

 

Gnanavelu, 

I have the same issue!

Did you happen to find a solution?

 

Thank you.

Anyone can figure out this issue...?

Windows : Win 7 Professional

Browser : Chrome - Version 50.0.2661.102 m

Attached the PDF file for test purpose


I wonder if this is a browser issue - what Windows platform, what browser, what version,  what plugins for PDF

Do you have a PDF created by someone else to try?

I tried with simple PDF file of 1-page which doen't more than four lines of text, unable to view the thumbnail view. I wanna to view the PDF thumbnail itself in page like i attached below

 

Thumbnail PDF.PNG

I have no problem displaying PDFs as links or thumbnails - I can even toggle between either way in the edit screen - refer my screen shots in this posting

Why I cannot preview but only download pdf file?

You must have a bad file format or a problem in the configuration of your Confluence

Try another PDF file from another source?

It may be the version of the pdf.  I know that there is no preview for Excels in Excel 97 format.  It must have the new extension - .xlsx

My concern about PDF only. I used Adobe Reader XI version 11.0.16

This could be an issue with the file. Perhaps the Application Log is telling us an error.

Again it shows the same. Even i tried with the resize of thumbnail option also.

what happens if you re-add it to the page?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,387 views 7 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you