It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to use Confluence Server mobile app

Hello, I'm having some trouble getting the Confluence Server mobile app to connect to my self-hosted Confluence server (internally - no VPN).  I'm running it on an Ubuntu server, proxied by Nginx with a self-signed SSL certificate.

I've:

  • Installed the self-signed certificate on my iPhone
  • Ensured Nginx allows TLS 1.2
  • Ensured the Mobile, Like and Workbox-host plugins are enabled and up to date
  • Updated Confluence to the latest available version (6.15.7)
  • Tried with UFW disabled on the server (same result)

 

I initially tried to connect with SSL without the certificate installed, got the certificate error you'd expect when using self-signed certs and went through the KB for cert errors and installed my cert.  Now when I try to connect to the base url (https://subdomain.domain.org), I am greeted with the "We're missing something" error and told the app needs Confluence 6.8 or later.  I'm on 6.15.  The Learn more link brings me to the KB for enabling plugins, and I have confirmed they are enabled.

Any ideas?

Thanks!

1 answer

1 accepted

0 votes
Answer accepted

Hi,

nginx configuration issue?

Do you map Confluence to the root context? How do you access Confluence via browser (w/o the app)?

Best

JP

I access the site in Chrome mobile at https://wiki.domain.org.  Pretty sure it's mapped to the root context, too.  I'm no pro web-admin though, from server.xml: 

<Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">

I did try to connect straight through with the tomcat ports (8090 and 8443), but now that I think about it, I never adjusted the connector settings.  And, now that I have, I can get in without SSL (don't want to mess with tomcat certs for the test).

So, now I've switched back to my https proxy connector and looked at nginx.  I changed the config to only accept TLSv1.2 and after a reboot, I'm able to connect over SSL.

So, I'm good on my iPhone.  I did try it on my iPad, but didn't enable the certificate trust first before trying to connect.  When I fixed it, I still couldn't connect.  Started clean on a coworker's phone and it works.   I wonder if there's something in the app clinging to something?

Anyway, thanks for the help!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

How is your team having fun and bonding, remotely, utilizing Confluence?

Thanks everyone for answering last week’s question. The winner of the random drawing from those who commented is: @LarryBrock I’ll contact you separately with your prize details. This wee...

283 views 9 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you