It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The roadmap macro is broken.

The roadmap macro is not working. 

When I go to insert the macro the "Publish" button is disabled, and the macro is never added to the page, it does not get saved, it does nothing.

there is little to no real documentation out there that walks you through HOW to do this. 

Please fix it so I can use it

thanks

2 answers

0 votes
Ann Worley Atlassian Team Nov 03, 2017

I tested the Roadmap Planner macro in Confluence server version 6.4.3 and on Confluence Cloud. I was able to insert the macro by pressing the insert button, then the Publish button was no longer greyed out.

  • Are you on a self hosted version or using our Cloud offering? If you are using a self hosted instance, please let me know what version.
  • Please attach a screen shot of what you are seeing when you try to insert the macro, maybe I can spot something amiss.

We're also getting a new error as of last night:

Error rendering macro 'roadmap' : org/apache/batik/w3c/dom/ElementTraversal

Like Àlex Pérez likes this

We are getting this error message also. Anyone find a resolution?

Like Àlex Pérez likes this
Like Vicki Lea Tsang likes this

We are also having this problem.

Have raised a support ticket with Atlassian. Will update once I have a response.

Like Mark DiAntonio likes this

Just to be clear, we're using the cloud solution.

Atlassian are aware and apparently working on the issue. Here's the report for people to watch and vote on: https://jira.atlassian.com/browse/CONFCLOUD-64973

Trying to use templates in Confluence and got the exact same error:

Error rendering macro 'roadmap' : org/apache/batik/w3c/dom/ElementTraversal

Glad I'm not the only one and I found this thread.

Like Mark DiAntonio likes this

I have also problems with Roadmap Macro. After hard work of creating a great number of new lanes and bars it's disappointing that after clicking Insert, there's no warning but also no Roadmap diagram - absolutely nothing, like nothing was ever there. Very frustrating to start over, since of course there's no way to get back. Now, I click insert after adding few lanes and then publish and then go back to continue. Slow process. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Confluence

2019: All Wrap(ped) Up Like a Present

Hindsight might be 2020 but looking back, a lot of cool new features rolled out in 2019. From new collaboration and organizational powers to fresh templates and handy integrations, it’s been quite th...

245 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you