The content by label macro not working

Recently the content by label macro seems to have stopped working. After some initial investigation, it is only the labels that have been added in the last 2 weeks or so that are affected. Any older label seems to work in this macro. Any ideas why new labels would not allow this macro to function correctly?

Thanks in advance for any help.

2 answers

1 accepted

0 vote
Steven Behnke Community Champion May 26, 2016

Perhaps you need to index your content? This doesn't really happen but sometimes the index fails. If it happens multiple times you should open a support issue at support.atlassian.com.

Thanks for the quick reply. I'll give this a shot.

This was actually what I was going to first answer with.  You'll know it's an indexing problem if you go to Administration > Content Indexing > Queue Contents and see a long list of things needing to be indexed.  This is supposed to be processed every 30 seconds (or at least nightly), but if you're queue is still growing, please follow this workaround:

You can force Confluence to create a new index file:

 

    Stop Confluence.

    Delete the following folders from the home directory if they exist (# rm -Rf <dir>):

        <confluence-home>/index/

        <confluence-home>/journal/

    Start Confluence.

    Go to General Configuration page.

    Search for the Content Indexing option towards the bottom of the left side bar.

    Click on Rebuild.

 

The above steps will ensure that Confluence will create a new index file.

 

 

If you add new Labels to the page only, you must also Edit said page, select the Content by Label macro (e.g. the default "Related Articles" macro), click Edit on that, and also add the new labels to that.  When you first create the page, all of your labels for the page are automatically added to this macro, however any edits to the labels need to be done in both places (inconvenient I know). Also, if you move that page, you may need to edit the macro and change/update the Space that it is looking in (I just noticed this myself)

Just some additional info - I've been creating series of pages around different types of content. So for example, I created a couple of pages around peer reviews and  use this macro to create a "related pages" section on each page. I've been doing to for several months and it stopped working about two weeks ago (and only with new labels). When I go back and edit the page to add the label to the macro, it allows me to add the label (even prefilling as I type), however, after I save it and then the page, I get a "There is no content with the specified labels" message. If I replace it with an older label is works just fine. Thanks

Exactly what's happening here.. 

I ran the Index rebuild and it seemed to work for a minute. That is, the How To page now picks up the pages I added most recently. But when I added a new one just to test it, I'm back to the same problem.

I don't know if it's at all related but my Queue Contents list is filling up without being processed. The screen says "By default, the contents of the queue are processed every minute." but there were 1152 an hour ago, and 1174 now, and we're a pretty small shop. The index rebuild didn't affect this at all.

 

@Maggie Secara please see the actual answer of solving that that I replied as a comment to the other answer.  It'll solve your problem

 

@Geoff Wilson But I'm not talking about adding a new label to a page that .already exists. This is a brand new page, with just the one label. As you said above, "When you first create the page, all of your labels for the page are automatically added to this macro." No, they are not. They were until abut 3 weeks ago, but not now. That's what's not working

Like this:

  1. Click Create... and select How-to Article
  2. Click Next
  3. Enter a Name and click Create.
  4. Add some content and click Save.

This new page should appear automatically on the How-to Articles page, right? It does not. All the older pages are listed, but no new ones.

When I run the Index Rebuild as @Steve Behnke [DiscoverEquip.com] suggested, the How-to Articles content report table refreshes and the new page now appears on the list. That is the only way to make it do what it's supposed to do. 

Fortunately our Index is young and the rebuild only takes a few seconds, but this could be a serious problem eventually.

 

Steven Behnke Community Champion May 31, 2016

Either look at the logs to try and find a root cause or just restart your application and hope that fixes it.

The problem still occurs in confluence 5.10.7.  We have reindexed the content and restarted confluence.  The new pages are listed in the sidebar but are not captured by the label gadgetnot in label macro, only on sidebar.png

also the sort by Page Name is not working in the macro

Any progress with this? I experience the same as @Maggie Secara1 does ... reboot, reindex, delete index and build it from scratch works... for that moment... after that no updates again until another reindex... thanks

Restart and hope it fixes it is not a solution. Neither is reindexing constantly. This is a key feature that a lot of people use. Atllassian - this needs to be addressed. It is not a new issue and has significant impact on sites like ours that have a lot of content. This issue is nearly 2 years old.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

377 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you