Survey & vote macros: "problem casting a vote. Returned status: error"

We have the vote & survey plugin version 2.8.0 (com.nearinfinity.confluence.survey-plugin) installed on confluence 5.2.5.

After plugin installation,

- the macros do not show in the macro browser

- we can not edit the macro: it throws an error message reading "There is no metadata configured for this macro which means no configuration screen can be presented here.".

- when we vote we get the following error message: "There was a problem casting a vote. Returned status: error".

If I look at the failed request with firebug, I see that the vote macro complains about "There was a problem finding the specified ballot: Could not find the specified ballot with title ki? on the specified page!" I looked in the page source xhtml and the ballot is indeed present ...

What did I do wrong?

Cheers.

3 answers

this does not sound like easily reproducable. I would like to ask some basic questions. What kind and how long do you have the confluence installation (Kind, like default standalone. How much experience, like first week, several years, many other plugins, default language).

What would also help me:

* screenshots

i guess we can move on from there.

We have confluence 5.2.5 standalone and using confluence for years with a few plugins. The default language is English UK. Please see screenshot attached.

thanks

This is the popup returned when casting a vote

Hi Philippe,

thanks for the screenshot. Is it possible that your Test Page is your users profile space? Currently i have no access to a confluence installation, but will test it in a few days when i have one again. Maybe that could be an issue, never tested that before i guess.

Is it possible?

The settings within the plugin manager are all green after installation? I dont know any possible reason why it should not show up in the macro browser. And how were you able to add it to your content without the macro browser?

Edit: No a personal space is not the problem. Works like a charm. Somehow i am a bit clueless. You installed the plugin successful for the first time, went to a regular wiki page where the macro did not show up. Somehow you were able to add it, then you got an error while editing the macro and on voting the uneditable macro you got an error.

What am i missing :(

I just upgraded to 2.8.1 and it seems to work much better:

- I see now both macros in the macro browser

- vote works

- survey works

- I can edit the macros

Thanks!

I am glad it works now!

Frank, I'm using version 2.8.2 with Confluence version 5.4.3

I've the same issue. Will you recommend to downgrade or..?

"There was a problem casting a vote. Returned status: error, error: Bad Request

imho this is not a plugin failure but a osgi problem or something where confluence seems to have not correctly loaded the plugin, so any change can fix that problem, uninstall and reinstall the same version or downgrading and upgrading. So Confluence has to "initialize" the plugin again, i dont see any other problem here. Cant tell why confluence sometimes get stuck, it isnt reproducable (at least for me). Please tell me whether that resolved it.

Frank - thanks for a prompt reply!!

I made a uninstall and reinstalled (2.8.2), sadly it did not fix the issue. (It is only related to voting - adding or deleting comments works fine)

PS the Atlassian universial plugin manager, is version 2.17.8

Hi Finn,

hmm. I updated to the Plugin manager 2.17.8, uninstalled the survey plugin and installed freh. I have no problems in any form.

My next guess would be that you installed a plugin which hinders parsing of the wiki page, do you have a plain wiki space where you can try it? Another possibility would be to add this line to your log4.properties

log4j.logger.org.hivesoft.confluence=DEBUG

and check the according logfile when this error is produced. Can you go on from there?

Had an issue to get logging to work yesterday. Will give it a new go tomorrow. Thanks for the support!

upgrade to 2.8.1 fixed it.

upgrade to 2.8.1 fixed it.

Hi Philippe,

can you mark this as answered. Even when you accepting your own answer ? ;)

it always looks bad if tags have unanswered questions

thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,060 views 16 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you