Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,103
Community Members
 
Community Events
176
Community Groups

Some pages do not appear after space import and restriction removal

Hi everyone,

I have imported a space from a compatible Confluence-Server export file (name: Confluence-space-export-nnnnn-nn.xml.zip).

The import was conducted from the "General configuration -> Backup & restore -> Import from the home directory" admin section (import file size is 4GB, it was stored in the restore directory).

The import was successful (no errors occur during the import).

I resetted the newly imported space permissions from "General configuration -> Space permissions -> Recover Permissions" admin area. 

The site is now visible (including attachments).

The problem:

  • There were a few restricted pages, which I saw in the  "Space tools -> Permissions -> Restricted pages".
  • I deleted all restrictions, but the pages are still not visible.
  • The content resp. the pages are imported, because I can find them in the database. 

Is there a way to fix this issue? 

Thanks in advance for your help.

 

Kind regards

Pavel

 

  

2 answers

1 accepted

0 votes
Answer accepted

The solution that worked for me was the following: directly in the database I searched for the pages that are not visible and checked if there were any (old) CONTENT_PERM_SET entries. After deleting the entries and restarting the Confluence instance, the pages were visible again and I was able to restrict them again. 

Lessons learned:

  • CONTENT_PERM_SET entries are not being (?) correctly deleted after import
  • as Nitin suggested - remove all restrictions before export - this will safe an enormous amount of time and effort after import
0 votes

Hello @Pavel

I just checked the issue posted by you and can see there's already a bug logged for the issue where restricted pages are not exported as part of Space XML export in Confluence Data Centre.

As a workaround you need to remove restrictions on Pages before initiating export of space instead of removing restrictions after import.

Let me know if this helps.

Thanks

Nitin Rastogi

Hi Nitin, 

thanks for the response.

For future imports I'll remove the restrictions prior export, but now the import is already done, I can not revert it anymore, since the space is already in use in the new server. :-( 

So there is now way to view this pages again, except fetch the content from the database and recreate the page manually?

Thanks and regards

Pavel

Hi Pavel,

Yes, since the export is already imported and in use, restricted pages needs to be created manually if required in imported space.

Thanks

Nitin Rastogi

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
7.13.7
TAGS

Atlassian Community Events