Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Related articles doesn't exclude the current page

When I create new pages, the related articles list for that page always lists that page. It is silly for the page to "relate" to itself and takes up one of the related articles slots, preventing another relevant page from being show in its place.
How do I exclude the page from the list of related articles?

5 answers

I'm seeing this issue as well, we're on the cloud version of Confluence.

The problem remains after 2+ years.  What's up?

0 votes

Hi!

I couldn't find any bug report for this behavior yet. Would be possible to state which version of confluence you are using?

Can you try to use the latest version of confluence as such this might have been fixed.

If you can provide the exact steps to reproduce the problem in the latest version that would be great so we can open a bug report if we are successful.

Cheers,

Rodrigo

Stop being lazy, that's your job.

?

Four years and still no such simple option? To simply exclude current page?

We just switched to confluence/jira and what a productivity killer. I'm always spending time trying to figure out why basic things are just broken or have stupid behavior. I guess their motto is "just live with it".

The exact steps are:

1. Use the Content by Label macro on a page.

2. Page itself shows up as a Related Article on it's own page.

Like gillamc likes this

This a To-Do, see JIRA Service Desk issue: https://jira.atlassian.com/browse/JSD-540

The Confluence loud Ticket is in the status 'Gathering Interest'

https://jira.atlassian.com/browse/CONFCLOUD-5245

Did it gather enough interest yet?

While the fact that I'm searching for and reading this article I guess means this is still unresolved. Bummer.

  1. Edit Content by Label macro
  2. Show Options
  3. Exclude current page

Should be default, though! 

Unfortunately, that fix is only on the Server version, not the Cloud yet.


I'm following this issue here - https://jira.atlassian.com/browse/CONFCLOUD-5245

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

463 views 24 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you