Profile photos lost somewhere in upgrade from 3.3 to 4.0 to 4.2.11

We have been staging an upgrade to 4.x for some time on a development instance. We just took it up to 4.2.11. I just noticed the profile photos are all reset. Known problem? Work around?

2 answers

1 accepted

Unfortunately that is a known issue of the upgrade progress, CONF-22298. If you read through the ticket, there is a workaround in this comment.

We ran into this issue as a result of conflicting database and file system. i.e. the icons are still there, but the hashes used in the database no longer point there. Restore the DB and filesystem to the same version (pre-upgrade), and attempt the upgrade again. Do testing between each upgrade to isolate the step that causes the error, it will be very difficult for Atlassian to identify a bug (if there is one) without knowing which upgrade path caused the issue.

Watch the logs and ensure the DB upgrades complete successfully.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

763 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you