Profile photos lost somewhere in upgrade from 3.3 to 4.0 to 4.2.11

We have been staging an upgrade to 4.x for some time on a development instance. We just took it up to 4.2.11. I just noticed the profile photos are all reset. Known problem? Work around?

2 answers

1 accepted

Unfortunately that is a known issue of the upgrade progress, CONF-22298. If you read through the ticket, there is a workaround in this comment.

We ran into this issue as a result of conflicting database and file system. i.e. the icons are still there, but the hashes used in the database no longer point there. Restore the DB and filesystem to the same version (pre-upgrade), and attempt the upgrade again. Do testing between each upgrade to isolate the step that causes the error, it will be very difficult for Atlassian to identify a bug (if there is one) without knowing which upgrade path caused the issue.

Watch the logs and ensure the DB upgrades complete successfully.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

372 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you