Linking Applications to Confluence Error

Hey,

i really need your help because i can´t find a soulution.

When i try to link any application (for Example Jira->Confluence, Stash->Confluence, Bamboo->Confluence) i get the error in confluence:
”[Exception... "" nsresult: "0x805e0006 ()" location: "JS frame :: https://confluence.volleynet.at/s/a52bf2b500380ecdd5e4e39e79f22aa5-CDN/de_DE/5781/06be774e49836f55365352484cdb0bdbe01e119b.5/5/_/download/superbatch/js/batch.js?build-number=5781&locale=de-DE :: .send :: line 269" data: no]”

Also i get the Warning in Add-Ons in Confluence that the Base-Url is wrong.

But i can reach the Confluence Site via the Base Url https://confluence.volleynet.at.

Can some help me pl?

 

5 answers

This widget could not be displayed.

Hi Philipp, 

Could you tail the JIRA log (JIRA_HOME/log/atlassian-jira.log) and attempt to create the link to Confluence and check what error is being thrown?

Also, this plugin is really useful, give a try to install it both on JIRA and Confuence and let us know the result as well: https://marketplace.atlassian.com/plugins/com.atlassian.applinks.applinks-diagnostics-plugin 

This widget could not be displayed.

Hey Philipp,

The error related to JS frame is usually related to Proxy or the browser itself. May I ask if you are using proxy? If so, is it Apache or Nginx?

Can you please try to bypass it in order to try to create the applinks?

The logs also might help us on this case, as Benito's mentioned.

 

I hope it helps

Eduardo

hey eduardo, i think (as i mentioned i´m not in the system but configure the sites) we are using Apache. confluence is configured with port 8090, proyPort:443 nad proyname confluence.mysite.at what do you mean with "try to bypass it..?"

Hey Philipp, Bypass it would be to try to create the connection between the applications using the application IP and Port Number instead of the domain name that goes through your Apache. You'd need to set the base URL of both applications to the IP:PORT to create the applinks and once it's done you would could set the URL back to the domain name. Another thing is that you are using SSL, can you see if you are able to find any PKIX error on your logs? Let me know if it helps. Eduardo

nothing worked, i tried it with ip:port but this throws again the error, i try to geht the logs as fast as possible.

This widget could not be displayed.

ok i try to get the JIRA log from my administrator.

Meanwile i tried to install the app. It worked in JIRA but when i was searching it for confluence i could´t find it. I tried to upload the .jar file but the confluence told me that it is not working. I´m running Confluence 5.7.1.

Just like it doesnt matter i tried to test the connection and get everything excepted

  • HTTP Echo
    • (Echo response is inconsistent with request)
  • Authentication Check
    • Failed to authenticate against Confluence using: OAuthAuthenticationProvider TwoLeggedOAuthAuthenticationProvider TwoLeggedOAuthWithImpersonationAuthenticationProvider

 

This widget could not be displayed.

Ok i really don´t know why but know everything seems to work fine.

I just viewed the configuration

  1. in conf/server.xml

i set the ConnectPort the proyPort and proxyName

  1. in bin/setenv.sh

there i set the -DproxyPort and -DproxyName

 

i really don´t know why but seems to work fine, i don´t get any error when i link confluence to another server...

This widget could not be displayed.

Thank you all for your help we found a ProxyLink Error in our config files. Now everything is working!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

361 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you